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Chapter 1: The Alarm List
1.1 Introducing the Alarm List
Process alarms and 'IGSS Alarm'
IGSS Alarm is a fast and powerful alarm handling routine which is an integral part of the IGSS process control system. This is an enormous advantage to both the plant operator and the system designer as all interfacing between alarm management and process supervision and control functions is dealt with
automatically by IGSS.
Your plant signals an alarm situation whenever the control process generates an error which may be some
electrical equipment not functioning properly, or some measured values stepping out of the predefined limits. Thus it could for instance happen that the water level of a tank level rises dangerously high or a valve
did not close properly where it should have done. In all these cases, alarm signals of higher or lesser
importance are registered by IGSS and indicated to the operator in various ways:
l

l

l

l

The alarm counter, which is a special icon displayed on the screen in the taskbar or in a userdefined spot, is automatically incremented with each new alarm and thus indicates the number of
unacknowledged alarms.
The symbol in the process screen which represents the faulty plant component changes color or
begins to flash.
A text message explaining the nature of the alarm appears in the message line of the currently displayed process screen.
The alarm and all its relevant information is recorded in two lists
l

the Active Alarms

l

the Alarm Log

for evaluation, archiving, reporting and further processing.
l

Depending on its severity, the alarm may be announced by an acoustic signal and service personnel may be called over the paging system.

Below the Alarm List, you will find the Event List. Click here for further information.

How is an alarm identified ?
A process alarm is primarily identified by its alarm number .
Each alarm number is linked to a specific plant component - an object - and thus indicates that this particular object is in the state of alarm.
All characteristics of that alarm - priority, color, alarm text, acknowledged or not acknowledged - are
stored under this number.

Alarm characteristics
Apart from the identifying alarm number, each alarm is given a set of attributes which describe nature and
severity of the process alarm:
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l

Priority, from 1 to 255

l

Date and time of alarm occurrence

l

Date and time of alarm end

l

Time of alarm acknowledgement

l

Name of the faulty plant object

l

Name of the plant area to which the object belongs

l

Worst process value measured for the faulty plant object

l

Node (PLC) and driver identification

l

Name of the user who has acknowledged the alarm

These details are automatically recorded in both the alarm list and the alarm log.

The Alarm Count icon

The Alarm Count icon is a special icon that can be displayed on the local machine when the alarm
module is started. The Alarm Count icon provides the operator a quick overview of the alarms in the
system and the operator can access to the Active Alarms form by double-clicking the Alarm Count
icon.
The alarm count icon can be set up to display:
l

the number of objects currently in alarm

l

the number of currently active unacknowledged alarms (default setting)

l

the number of acknowledged and unacknowledged alarms

l

the number of alarms that match the used alarm filter

Enable and set up

The Alarm Count icon can be enabled in the Active Alarms form > View > Alarm Count. Display parameters for the Alarm Count icon can be defined in the System Configuration form > Alarm tab
> Counter group found in the IGSS Master > Design and Setup tab.
The alarm icon automatically adopts the color of the pending alarm with the highest priority so that you are
always informed about the severity of the alarms still awaiting acknowledgement and correction.
Alarm count icon placement

Taskbar
The alarm icon is permanently displayed, either in the taskbar in the bottom of the screen, provided that
the taskbar is enabled for your application, or in a predefined spot on the screen, irrespective of which process diagram is currently being displayed.

System tray
The alarm icon is also displayed in the system tray.
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The Alarm List
Click the picture for further information

Active Alarms versus Alarm Log
Every alarm triggered in the plant and defined as such during project design is principally
registered in two different generated automatically lists: The ALARM LIST and the ALARM LOG.
These lists provide the operator with important information about the alarm situation.
Active Alarms

Alarm Log

contains all pending alarms, i.e. those alarms that are
currently active.

Contains ALL process alarms,
including those that have been
acknowledged or whose cause
has in the meantime been corrected.

Alarms are automatically deleted from the list when
Alarms are not automatically
the alarm situation has ended AND the alarm has been deleted from the alarm log,
acknowledged. Alarms that are acknowledged but
irrespective of their ‘age’.
whose cause has not yet been eliminated, or alarm situations that have been corrected but not yet acknowledged, remain in the alarm list, i.e. they are
considered as being active or pending.

The alarm list is a subset of the alarm log.

The alarm log contains the
pending alarms registered in
the alarm list AND the ‘old’
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Active Alarms

Alarm Log

alarms.
You may define your own sorting and filter criteria and
thus exactly define which type of alarms you want to
have displayed in the alarm list and in which format
and layout.

You yourself define the period
of time to be covered by the
alarm log. You may for
instance decide to call up an
alarm log that shows all
alarms - acknowledged or not
– from the last 24 hours.

All edit functions offered in the menu bar (filter, sort,
find, note, freeze, delete, update etc.) can be applied
to the alarm list.

All edit functions offered in
the menu bar (filter, sort,
find, note, freeze, delete,
update etc.) can be applied to
the alarm log.

Alarm or Event log display limits

If the alarm or event log contains records that exceed the user-defined maximum alarm or event log limit,
the latest alarm or event logs will be displayed. To find older alarm or event logs, you must create and
apply an alarm or event log filter to display the desired alarm or event log entries.
The maximum number of alarm log entries is defined in the Max. alarm log entries field on the Alarm
tab of the System Configuration form.

Priority
Each alarm is given a priority in the range of 1 to 255, 255 being the highest priority.
The reaction of IGSS Alarm to alarms of different priorities is defined during system design in the Definition module.
Alarms of low priority (Priority 1 and 2) may be self-acknowledging and not even make the relevant symbol in the process screen change color or flash, whereas alarms of high priorities may cause an automatic
printout, personnel to be called over the paging system, return a signal to the PLC in order to set off an
acoustic alarm etc.
These reactions are decided on during system design when the alarm is given its alarm number, priority
and other characteristics, such as color changes.

Alarm Priorities and Analog and Table objects
An analog or table object can only display one active alarm at a time and only the alarm with the highest
priority will be displayed.
If you have multiple alarms for the analog or table object, for example if a High Limit alarm is triggered,
and the object value then triggers the High Alarm, two alarms will be triggered, but only the alarm with
the highest priority will be displayed in the Active Alarm list. The other alarm will be placed in the Alarm
log, but will be unacknowledged.
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Alarm priorities and Digital objects
Digital objects and analog or table objects whose alarms are controlled by the PLC machines may contain
up to 32 simultaneous alarms if the Single Bit option is used when setting up the object template.

Digital objects can only be set up with the Single Bit option if a Digital Object Template is used to create the object.

Alarm priorities and Counter objects
You can only define one alarm for Counter objects and therefore only one alarm is displayed.

1.2 Viewing the Alarm List
Open the Alarm List or the Alarm Log
You can open the Active Alarms form by clicking the Alarm Count icon (if the alarm count icon is enabled)
or clicking the Alarm button found on the IGSS Master > Home tab.

The Active Alarm list and Alarm Log column list
List of the columns in the Active Alarm list and Alarm Log:
l

S.No. = Sequence Number

l

Start Date

l

Start Time

l

Acknowledge Time

l

End Time

l

Object Name

l

Worst Value

l

Alarm Text

l

Area Name

l

Object Description

l

Value

l

Priority

l

Alarm Number

l

Acknowledge Date

l

End Date

l

Alarm State

l

Driver Id.

l

Node Id.

l

User name

l

Arrival date

l

Arrival time

l

The icons

l

Last Changed Date
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l

Last Changed Time

l

Action

You can adjust the information displayed or printed in the Active Alarm list or Alarm log according to
your requirements, removing and adding columns as needed.
See Also

"Add columns" on page 102
"Change the column width" on page 103
"Change the sorting order in the list" on page 108
"Define a new filter" on page 91
"Set a default Alarm log or Event log filter" on page 96
"Define special filter parameters" on page 93
"Delete an existing filter" on page 93
"Edit an existing filter" on page 92
"Rearrange the columns" on page 100
"Remove columns" on page 101
"Rename a column" on page 101
"Restore the Alarm list default format" on page 106
"Save the list format as the default format" on page 108

1.3 Predefined System Alarms
List of predefined alarms
The alarm numbers between 1 and 100 have been reserved for reporting system alarms in IGSS. System
alarms are used for generating warnings to assist in controlling and troubleshooting IGSS. When activated,
these alarms will appear in the Active Alarms form.

Do not delete or re-use the predefined alarms for alarm indication purposes
in your objects in your configuration. These alarms are used for reporting
specific system events.
To view a complete list of all alarms in the configuration - system alarms as well as user-created alarms, in
the Supervise module, click Tools > Alarms to open the Alarm Details form.
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Alarm See-Thru and Communication errors
Alarm number 1 is used for alarm See-Thru and the alarm numbers between 10 and 51 are reserved for various communication errors (the communication ports, the PLC, the data collection engine, etc.).

Alarm
Number

1

Description

An object on the diagram a button is linking to is in alarm.
The alarm border surrounding the button will blink in the alarm color. You can edit the blink
and the alarm color.

10 and 11 The setup of drivers is erroneous.
20 and 21 Communications ports are faulty.
30 to 39

Extended event-driven communication drivers fail; please refer to driver documentation.

40

A general PLC error has occurred. Refer to PLC documentation.

41 to 45

Driver communication errors. Refer to driver documentation.

46

Connection to the PLC program is missing. The physical connection may be in order, but for
some reason the PC has not received the expected "I'm alive" message.

47

Extended event-driven communication drivers fail. Refer to driver documentation.

50

Incomprehensible data from the PLC is received by the data collection engine (DC).

51

Too much data output is generated, for example, if a DDE link generates too much data.

Errors and messages related to other system parameters
The alarm numbers between 80 and 100 are reserved for alarms related to system conditions and errors.

Alarm
Number

Description

80

A network connection to the station type AB-server is lost.

86

Monitors the Backup folder for the configuration data specified in the System Configuration
form> Files tab > Automatic Backup group > Select backup folder field.
The alarm will trigger when:

87

l

the specified backup folder is inaccessible through the network

l

there is less than 1 GB data remaining in the backup folder

l

the specified backup folder cannot be written to

This alarm is used when the Data Collector encounters an unexpected error. The alarm text is
"Internal system problem."
The Data Collector will attempt to recover and if no more errors occur the alarm will be
ended. If the Data Collector cannot recover, the Data Collector will be terminated and restarted by the IGSS Master. When this alarm has been triggered, basic system health should be
checked (data collection and logging working as expected)
You can define Data Collector recover and re-start options in the Alarms on Internal Errors
and suppressed logging group on the Data Collection tab in the System Configuration
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Alarm
Number

Description

form.
88

Logging of LOG, BCL and alarms to disk is stopped for any reason. Any error writing to the
LOG, BCL and/or Alarm files or any error accessing the Report folder will also trigger this
alarm.
The alarm text is "Data logging has stopped".
The alarm is automatically ended when the conditions triggering the alarm no longer are
present.
You can negate this alarm from being triggered by clearing the Generate alarm no. 88 if
writing of historical data has been stopped check box on the Data Collection tab in
the System Configuration form.

90

An alarm has been generated by an Event.

91

An operator has attached an alarm inhibit flag to all the alarms defined for the given object.

92

An operator has attached an alarm inhibit flag for specific alarms defined for a given object.

93

An operator has attached a Notifier alarm inhibit flag for all alarms defined for a given object.

94

The current disk usage exceeds the High Limit value of the predefined System object. The
default value is 80 %.

95

The current disk usage exceeds the High Alarm value of the predefined System object. The
default value is 90 %.
All writing to the harddisk is suspended when this alarm occurs and log files (*.log) or base
class files (*.bcl files) will not be saved.

96

An operator writes a comment on the Object note tab of an object.

97

An alarm normally sent out to the WinPager module has been temporarily disabled.

98

An Event has been generated in the Event list.

99

An undetermined alarm has been received on the IGSSserver. This alarm is used when IGSS
receives an error message that it is unable to find a matching alarm text for. This situation
could arise if an alarm text was modified after the installation of the configuration.

100

(reserved for future use by the system)

See Also

"Driver error codes in the Alarm List" on page 23

Driver Communication Errors
Driver error codes in the Alarm List
Viewing error codes

A driver communication error will result in an alarm in the Alarm List. The alarm number will be one of the
predefined alarm numbers for driver errors and the alarm text will be the general alarm text associated with
that number. The driver error code itself is shown in the Worst Value field. Its syntax is described below.

- 23 -

IGSS V13, User Guide

Help on error codes

If you get a driver error, right-click the alarm line and choose Driver Error Help.
To view the full list of driver-specific error codes, choose Driver Help.
Error code syntax

A driver error code consists of three or four elements separated by periods. The first three elements are
always present, whereas the fourth element is an extended error code which may be omitted depending on
whether IGSS has registered the extended error code from the PLC manufacturer.
The error code convention is as follows:
<Drv No>.<Node No>.<IGSS error code>.<Extended error code>
where:
Syntax

Description

Format

Example

<Drv No>

The number of the driver used.
You can find the driver ID in the ID column
of the Select Communication Driver dialog or on the Driver Information tab for
the selected driver.

Decimal

19
(Telemechanique
Xway
protocol driver 7TXWAY)

<Node
No>

The node number assigned to the PLC in the
System Configuration form.

Decimal

05
for node number
5

<IGSS
error
code>

The IGSS error code

Hexadecimal

130A

<Extended
error
code>

Is the extended error code which typically
Hexadecimal
comes from the PLC or the PLC interface software

0c02

The full error code in the Worst value field would thus be 19.05.130A.0c02.
See Also

"Extended Error Codes" on page 24
"List of general driver error codes" on page 25
Extended Error Codes
Extended error codes originate from the PLC interface software or from the Windows operating system and
are displayed in the Active Alarms form as the fourth (and last) element of the driver error code.
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Error code descriptions

The link below contains the error code descriptions received from the PLC manufacturers. In some cases,
the extended error code may be missing if information concerning the error code has not been imparted.
For further details about these error codes, refer to the documentation from the PLC manufacturer.
Windows error codes

In some cases, the extended error code is a Windows error code. A Windows error code is generated by the
WIN32 API and is registered by the IGSS communications driver.
See Also

"List of general driver error codes" on page 25
"Driver error codes in the Alarm List" on page 23
List of general driver error codes
IGSS includes a number of predefined alarms used for reporting general driver communication errors in the
Active Alarms form. The alarms will be reported on the predefined driver communication object named
Driver or the relevant node status object, if defined.
The communication errors can also be viewed in the Communications tab in the IGSS Master as shown
below.
Alarm number

Alarm text

Communications error
text

10

Global driver configuration error

CONFIGERR

11

Global driver resource problem

DRVRESRC

12

Servers def time not the same

DEFTIMEERROR

20

Errors occurred during input fm
port

LOWLEVERRI

21

Errors occurred while output to
port

LOWLEVERRO

22

Errors reported by GetLastError()
in

IOERRORI

23

Errors reported by GetLastError()
out

IOERRORO

24

Errors reported by ClearCommError() in

COMMERRORI

25

Errors reported by ClearCommError() in

COMMERRORO
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Alarm number

Communications error
text

Alarm text

40

In remote PLC reported by protocol

PLCSYSERR

41

Message protocol errors while
input

PROTOCERRI

42

Message protocol errors while output

PROTOCERRO

43

Packet level error during input

PACKETERRI

44

Packet level error during output

PACKETERRO

45

A bad packet received and
returned

BADPACKET

46

Keep alive timeout

KPALV_TO

47

Errors from dialup module

DIALUPERR

48

DCA-TCP: Error group for remote
DCA's

DCATCPERR

49

Error codes received from
AlarmNet

ALARMNETERR

50

Errors generated by DC at packet
in

DCPACKETI

51

Errors generated by DC at packet
out

DCPACKETO

The error code itself is shown in the Worst value field of the Active Alarms form. The Error description field in the table describes the cause of the error and suggests corrective action.
Worst
value1

Error Description

Internal error
text

0x0040

No buffer or request blocks

NO_REQBUF

0x0041

No scan buffers

NO_MSGBUF

0x0042

Ring buffer is full (B.060)

RBUF_FULL

0x0042

Received buffer does not match scan record

SREC_ERR
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Worst
value1

Error Description

Internal error
text

0x0044

Received buffer has unexpected length

LEN_ERR

0x0045

No channel exists for requested node

NO_CHAN

0x0046

Unexpected character received

CHAR_ERR

0x0047

Wrong BCC/FRC/CRC code in telegram

CRC_ERR

0x0048

Unsupported data type

TYPE_ERR

0x0049

Unsupported data group

DB_ERR

0x004A

Unsupported offset

OFFSET_ERR

0x004B

Transmit waiting for flow control signals (i.e. device off or cable is
broken)

TX_FLOWCTRL

0x004C

Node suspended by operator.

ONLINESUSPEND

0x0050

Open timeout

TO_OPEN

0x0051

Connect request timeout

TO_CR

0x0052

Send timeout

TO_XMIT

0x0053

Receive timeout

TO_RECV

0x0001

Cause: An event telegram was received with an invalid type value
Action: Check the PLC program that sends the telegrams

DC_INVTYPE

0x0002

Cause: An event telegram was received with a length that is shorter then
allowed
Action: Check the PLC program that sends the telegrams

DC_BADLEN

0x0004

Cause: An event telegram was received with a type message code that is
not supported by DC
Action: Check the PLC program that sends the telegrams

DC_NOSUPPORT

0x0005

Cause: An event telegram was received with a type message code that is
not supported by DC as an inbound packet
Action: Check the PLC program that sends the telegrams

DC_NOTINPKT

0x0006

Cause: An event telegram was received with an object address that is not
in the configuration
Action: Check the PLC program that sends the telegrams

DC_INVADDR

0x00e1

Cause: An event telegram was received with a bad type value.
Action: Check the PLC program that sends the telegrams

_7TPOLLED_
BADTYPE

0x00e2

Cause: An event telegram was received with a length that is longer then
allowed
Action: Check the PLC program that sends the telegrams

_7TPOLLED_
BADWLEN

0x00e3

Cause: An event telegram was received with a wrong timestamp or an

_7TPOLLED_
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Worst
value1

Error Description

Internal error
text

address request with wrong type.
Action: Check the PLC program that sends the telegrams

BADCONT

0x00e4

Cause: A time synchronization telegram was received from a node that is
not time master.
Action: Correct the problem in the System Configuration form.

_7TPOLLED_
BADTSYNCH

0x00e5

Cause: Invalid Minor State
Action: Internal error

_7TPOLLED_
DIALUP_
MINORSTATE_
ERROR

0x00e6

Cause: Unable to establish call
Action: Check modem and phone line

_7TPOLLED_
DIALUP_
CONNECT_
TIMEOUT

0x00e7

Cause: Driver can't find node to call
Action: Check that node definition in System Configuration form and the
Definition modules match.

_7TPOLLED_
DIALUP_NODE_
UNDEFINED

0x00e8

Cause: Can't perform a proper disconnect
Action: Check modem

_7TPOLLED_
DIALUP_
DISCONNECT_
TIMEOUT

0x00e9

Cause: No valid response to historical data request
Action: Check quality of phone line.

_7TPOLLED_
DIALUP_
HISTDATA_
TIMEOUT

0x00ea

Cause: Timeout reading valid node number in calling PLC.
Action: Check that correct node number is written into the right PLC
address. Remember to write node number in SATTR16 if COMLI protocol.
Check for correct Data Group and Word Offset in the System Configuration form > Modem > Remote.

_7TPOLLED_
DIALUP_
PREEVENT_
TIMEOUT

0x00eb

Cause: Phone connection disconnected by remote party.
Action: Re-establish connection manually.

_7TPOLLED_
DIALUP_GOT_
DISCONNECTED

0x00ec

Cause:IGSS could not read a valid node number in the calling PLC.
Action: Make a scanned analog object that addresses the location in the
PLC where you expect to find the node number. Call the PLC from IGSS
and verify that the node number is correct.

_7TPOLLED_
DIALUP_
ILLEGAL_NODE_
NO

0x00ed

Cause: Unable to establish call to PLC.
Action: Check phone number, modem and cable.

_7TPOLLED_
DIALUP_
CONNECT_
FAILED

0x00ee

Cause: Timeout writing scan complete indication to the PLC

_7TPOLLED_
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Worst
value1

Error Description

Internal error
text

Action: Check for correct Data Group and Word Offset and value in the
System Configuration form > Modem > Remote

DIALUP_
POSTEVENT_
TIMEOUT

0x00ef

Cause: Too long outbound message.
Action: Check for correct segment size in System Configuration form.

_7TPOLLED_
OUTBOUND_
LEN_ERR

0x00f0

Cause: Too long outbound mailbox message
Action: Check for correct segment size and mailbox size in the System
Configuration form.

_7TPOLLED_
MAILBOX_LEN_
ERR

0x00f1

Cause: The time interval for collection of historical data was set to zero.
The program modified the interval to 60 seconds.
Action: Setting the interval in the System Configuration form to zero is
only valid if the driver can read actual interval in the PLC.
Correct the interval in System Configuration form > Node > Connection Misc. > Configure > Interval.

_7TPOLLED_
INVHISTTIME

0x00f2

Cause: There is no dummy node configured for the alarm modem.
Action: Add a node to the alarm modem in the System Configuration
form.

_7TPOLLED_NO_
ALARMNODE

0x00d5

Cause: A telegram was received that was too long for the program.
Action: Check that the PLCs are sending valid telegrams, then contact
IGSS Support.

_7TSICOS_
EBADTLEN

0x00d7

Cause: The link to the node is down.
Action: Check that the PLC is running and that the connection is working

_7TSICOS_
ELINKDOWN

0x00d8

Cause: No keep alive telegram was received in the expected time
Action: Check the PLC program

_7TSICOS_
EKPAEXPIR

0x00d9

Cause: A bad sequence number was received
Action: Check the PLC program

_7TSICOS_
EBADRCVSEQNO

0x00da

Cause: No buffer available
Action: Increase number of messages for the driver in the System Configuration form.

_7TSICOS_
ENOMOREBUF

0x00dd

Cause: Illegal node number specified.
Action: Remove the object in the IGSS configuration that belong to the
illegal node or create the node in the System Configuration form.

_7TSICOS_
EILLEGALNODE

1 in Alarm List and error code in Communications tab in IGSS Master.
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1.4 Acknowledging Alarms
Acknowledge alarms in the alarm list

Procedure

1. In the Alarm List, select the alarm message you wish to acknowledge.
2. In the function menu, select Actions → Acknowledge.

First Shortcut

1. You are inside the Alarm List.
2. Click on the alarm message which you wish to acknowledge.
3. Click the right mouse button.
4. This opens the Actions function box and places it immediately next to the selected message so that you can now conveniently activate the Ack function.

Second Shortcut

1. You are inside the Alarm List.
2. Click on the alarm message which you wish to acknowledge.
3. Double click on the left mouse button. The alarm is acknowledged.

See also

Acknowledge alarms in the process diagram
You are in the online supervision mode and the symbol of a process object starts flashing, which means it is
in the state of alarm.

Procedure

1. Click on the object that indicates an alarm state.
2. In the menu bar, go Edit → Acknowledge alarm.
3. The alarm is now acknowledged.

Shortcut
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1. Right-click on the object that indicates an alarm state.
2. A popup menu appears next to the object offering you the Acknowledge command.
3. Click Acknowledge. The alarm is now acknowledged.

See also

1.5 Inhibiting and Removing Alarms
Inhibiting Alarms
You can temporarily inhibit alarms on IGSS objects, preventing specific or all alarms from being sent to the
Active Alarm form until you remove the alarm inhibition again. The present alarm will not be affected and
must be acknowledged and ended as any other alarm. Only new alarms from that object will be inhibited.
Inhibit alarms if the process component is being serviced, renders irrelevant alarms for other reasons or to
prevent additional alarms disturbing work on the component.
If multiple objects share the same alarm number, inhibiting a alarm only inhibits alarms from that particular
object. All other objects can still trigger the same alarm numbers. You cannot inhibit all alarms for all
objects in one process.
You can inhibit alarms for objects directly on the object in the Supervise module or through the Active
Alarms form.
When you inhibit one or more alarms for an object, a system alarm will be generated and displayed in the
Active Alarms form and the Inhibit alarms option in the object menu in the Supervise module will be
displayed with a check mark to indicate that the object contains one or more inhibited alarms.

It is possible to remove operator access to the object menus in Supervise. If this is the case, inhibiting alarms and reactivating inhibited alarms is not possible in the Supervise module.

Inhibit specific alarms
You can inhibit specific alarms for the object either through the Active Alarms form or directly on the
object through the Supervise module.

Inhibit specific alarms in Supervise
To inhibit specific alarms on an object in Supervise:

1. Click the object on the diagram and select Inhibit Alarms to open the Inhibit Alarms form.
2. In the Inhibit Alarms form, select the Inhibit only individual alarms on the object as
selected below check box
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3. If you want to inhibit other alarms not configured for the object, select the Also show alarms
that may be generated from code check box 1.
4. In the group box below the Inhibit only individual alarms on the object as selected
below check box, select the alarms you want to inhibit.
5. Click the OK button to save and close the Inhibit Alarms form.

1 It is possible to create VBA procedures in IGSS which can trigger an alarm for an object, even if the spe-

cific alarm has not been configured for that object. You can inhibit these alarms in the same fashion as
alarms that have been directly configured for the object.

Inhibit specific alarms in the Active Alarms form
To inhibit specific alarms on an object in the Active Alarms form:

1. In the IGSS Master > Home tab, click the Alarm button to open the Active Alarms form.
2. In the right pane of the Active Alarms form, right click the alarm you want to inhibit and select
Inhibit Alarm.

When you inhibit a specific alarm, a new system alarm will be registered in the Active Alarms
form indicating that an alarm has been inhibited. The system alarm number is 92 with the alarm text Alarm
Inhibit (specific alarms). You can acknowledge the system alarm number 92, which will move the alarm to
the Alarm Log.

Inhibit all alarms
You can inhibit all alarms for the object either through the Active Alarms form or directly on the object
through the Supervise module.

Inhibit all alarms on an object in Supervise
To inhibit specific alarms on an object in Supervise:

1. Click the object on the diagram and select Inhibit Alarms to open the Inhibit Alarms form.
2. In the Inhibit Alarms form, select the Inhibit all alarms that have been configured on
this object check box
3. If you want to inhibit other alarms not configured for the object, select the And inhibit individual alarms on the object as selected below check box and the Also show alarms
that may be generated from code check box 1.
1. In the group box below the Inhibit only individual alarms on the object as
selected below check box, select the alarms you want to inhibit. You must also
select any alarms configured on the object.
4. Click the OK button to save and close the Inhibit Alarms form.
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1 It is possible to create VBA procedures in IGSS which can trigger an alarm for an object, even if the spe-

cific alarm has not been configured for that object. You can inhibit these alarms in the same fashion as
alarms that have been directly configured for the object. You can click the Select All button to select all
the alarms displayed in the group box.

Inhibit all alarms on an object in the Active Alarms form
To inhibit specific alarms on an object in the Active Alarms form:

1. In the IGSS Master > Home tab, click the Alarm button to open the Active Alarms form.
2. In the right pane of the Active Alarms form, right click the alarm you want to inhibit and select
Inhibit all Alarms.

When you inhibit a specific alarm, a new system alarm will be registered in the Active Alarms
form indicating that an alarm has been inhibited. The system alarm number is 91 with the alarm text Alarm
Inhibit (All alarms). You can acknowledge the system alarm number 91, which will move the alarm to the
Alarm Log.
See Also

"Reactivating inhibited alarms" on page 33
"Inhibit Notifier Alarms" on page 35
"Remove Notifier Inhibition" on page 36

Reactivating inhibited alarms
You can reactivate specific inhibited alarms or all inhibited alarms for an object, either through the Active
Alarms form or directly on the object in the Supervise module.
When you reactivate inhibited alarms, the Active Alarms form will start registering alarms on the object.
and the system alarm that was generated when the alarms were inhibited will be ended and moved in the
Alarm log with the date and time the inhibited alarms were reactivated registered in the End Date and End
Time fields.

In the Supervise module
Inhibited alarms will always be displayed on the object in the Supervise module and you can inhibit and
reactivate an inhibited alarm directly in the Supervise module.

It is possible to remove operator access to the object menus in Supervise. If this is the case, inhibiting alarms and reactivating inhibited alarms is not possible.

Reactivate a specific inhibited alarm on an object in the Supervise module
To reactivate a specific inhibited alarm on an object in Supervise:
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1. Click the object on the diagram and select Inhibit Alarms to open the Inhibit Alarms form.
2. In the Inhibit Alarms form, In the group box below the Inhibit only individual alarms on
the object as selected below check box, clear the alarms you want to inhibit.
3. Click the OK button to save and close the Inhibit Alarms form.

Reactivate all inhibited alarms on an object in the Supervise module
To reactivate a specific inhibited alarm on an object in Supervise:

1. Click the object on the diagram and select Inhibit Alarms to open the Inhibit Alarms form.
2. In the Inhibit Alarms form, In the group box below the Inhibit only individual alarms on
the object as selected below check box, clear all the alarms to inhibit.
If you select the Do not inhibit any alarms on this object check box, all inhibited alarms
for the object will be reactivated.

3. Click the OK button to save and close the Inhibit Alarms form.

In the Active Alarms form
You can reactivate the inhibited alarm for the object either by reactivating the alarm on which the inhibition
was created or by reactivating the system alarm which was created when the alarm inhibition was created.
If you have acknowledged the system alarm number 91 or system alarm number 92, they are no longer displayed in the Active Alarms form, but are instead displayed in the Alarm Log list.
If you want to reactivate these inhibited alarms for an object through the Active Alarms form, you must
first open the Alarm Log in the left pane of the Active Alarms form, filter the Alarm Log to find the relevant system alarms and then reactivate the inhibited alarm.

Reactivate a specific inhibited alarm for an object in the Active Alarms form
To reactivate a specific inhibited alarm on an object in the Active Alarms form:

1. In the IGSS Master > Home tab, click the Alarm button to open the Active Alarms form.
2. In the right pane of the Active Alarms form, find the alarm number 92 with the alarm text
Alarm Inhibit (specific alarm) for the object you want to reactivate the inhibited alarm for.
You can create a new filter to find all inhibited alarms (Alarm number 92) or you can sort the Active Alarms form by clicking the Alarm Number or Object Name column heading.

3. Right click the relevant alarm number 92 to open the options menu. The Inhibit Alarm option
is displayed with a check mark.
4. Select the Inhibit Alarm to clear the check mark and reactivate the inhibited alarm.

Reactivate all inhibited alarms for an object in the Active Alarms form.
To reactivate all inhibited alarms on an object in the Active Alarms form:
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1. In the IGSS Master > Home tab, click the Alarm button to open the Active Alarms form.
2. In the right pane of the Active Alarms form, find the alarm number 91 with the alarm text
Alarm Inhibit (all alarms) for the object you want to reactivate the inhibited alarm for.
You can create a new filter to find all inhibited alarms (Alarm number 91) or you can sort the Active Alarms form by clicking the Alarm Number or Object Name column heading.

3. Right click the relevant alarm number 91 to open the options menu. The Inhibit All option is displayed with a check mark.
4. Select the Inhibit All to clear the check mark and reactivate the inhibited alarm.

See Also

"Inhibiting Alarms" on page 31
"Inhibit Notifier Alarms" on page 35
"Remove Notifier Inhibition" on page 36

Prevent Alarm Inhibition
In some IGSS configurations, operators are not permitted to inhibit alarms.
You can configure an operator station to prevent alarms from being inhibited by all operators working on
that operator station.
To prevent operators from inhibiting alarms

1. In the IGSS Master > Design and Setup tab, click the System Configuration button to
open the System Configuration form
2. In the left pane of the System Configuration form, select the operator station you want to configure.
3. In the right pane of the System Configuration form, click the Supervise & Language tab
and clear the Enable Inhibit alarms menu check box
4. Click File > Save Project and close the System Configuration form.
The IGSS configuration will be restarted for the changes to take effect.

Inhibit Notifier Alarms
You can inhibit alarms on the object from being sent to operators through the Notifier module. The alarms
can still be acknowledged and ended from within IGSS, but the alarms will not be sent to the Notifier server
for processing and forwarding to on-duty operator cell phones. The present alarm will not be affected and
must be acknowledged and ended as any other alarm. Only new alarms from that object will be inhibited.
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You can remove the Notifier alarm inhibition for the object again, restoring Notifier alarm notification forwarding.
You can inhibit alarms for objects directly on the object in the Supervise module or through the Active
Alarms form.
When you inhibit Notifier alarms for an object, a system alarm will be generated and displayed in the Active Alarms form. The system alarm number is 93 with the alarm text is Notifier Inhibit. You can acknowledge the system alarm number 93, which will move the alarm to the Alarm Log.
The Inhibit alarms option in the object menu in the Supervise module will be displayed with a check
mark to indicate that the object contains one or more inhibited alarms.

It is possible to remove operator access to the object menus in Supervise. If this is the case, inhibiting alarms and reactivating inhibited alarms is not possible in the Supervise module.

Inhibit Notifier alarms for the object in the Supervise module

1. Click the object on the diagram and select Inhibit Alarms to open the Inhibit Alarms form.
2. In the Inhibit Alarms form, Inhibit alarm transmissions via Notifier group, select the
Disable sending alarm information on this object until I manually re-enable option.
3. Click the OK button to save and close the Inhibit Alarms form.

Inhibit Notifier alarms for the object in the Active Alarms form

1. In the IGSS Master > Home tab, click the Alarm button to open the Active Alarms form.
2. In the right pane of the Active Alarms form, right click the alarm you want to inhibit and select
Inhibit Notifier.

See Also

"Remove Notifier Inhibition" on page 36
"Inhibiting Alarms" on page 31
"Reactivating inhibited alarms" on page 33

Remove Notifier Inhibition
You can remove the inhibited Notifier alarm for the object either by removing the Notifier alarm inhibition
on the alarm itself or by removing the Notifier alarm inhibition on the system alarm which was created
when the Notifier alarm inhibition was created.
If you have acknowledged the system alarm number 93, it will no longer be displayed in the Active
Alarms form, but is displayed in the Alarm Log list instead.
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If you want to reactivate the inhibited Notifier alarms for an object through the Active Alarms form, you
must first open the Alarm Log in the left pane of the Active Alarms form, filter the Alarm Log to find the relevant system alarm and then reactivate the inhibited alarm.

It is possible to remove operator access to the object menus in Supervise. If this is the case, inhibiting alarms and reactivating inhibited alarms is not possible.
Remove Notifier alarm inhibition for the object in the Supervise module

1. Click the object on the diagram and select Inhibit Alarms to open the Inhibit Alarms form.
2. In the Inhibit Alarms form, Inhibit alarm transmissions via Notifier group, select the
Enable alarm information on this object as per standard configuration option.
3. Click the OK button to save and close the Inhibit Alarms form.

Remove Notifier alarm inhibition for the object in the Active Alarms form

1. In the IGSS Master > Home tab, click the Alarm button to open the Active Alarms form.
2. In the right pane of the Active Alarms form, find the alarm number 93 with the alarm text
Inhibit Notifier for the object you want to reactivate the inhibited alarm for.
You can create a new filter to find all inhibited Notifier alarms (Alarm number 93) or you can sort
the Active Alarms form by clicking the Alarm Number or Object Name column heading.

3. Right click the relevant alarm number 93 to open the options menu. The Inhibit Notifier option
is displayed with a check mark.
4. Select the Inhibit Notifier to clear the check mark and reactivate the inhibited alarm.

See Also

"Inhibit Notifier Alarms" on page 35
"Inhibiting Alarms" on page 31
"Reactivating inhibited alarms" on page 33

Removing Alarms
You can remove an alarm from the active alarm list by selecting the alarm and clicking the Actions >
Remove Alarm in the Active Alarms form.
The selected alarm will be removed from the active alarm list and placed in the alarm log with the user
name. The Audit trail database will also be updated if Audit trail functionality has been enabled for the configuration. The selected alarm will be removed from the active alarm list even if the alarm has been inhibited or acknowledged.

Note that the alarm will be removed, but not the object value that triggered the alarm. The object will
still display the value that triggered the alarm in the process diagram. The alarm will be re-evaluated
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when the object value is renewed again and if the object value is sufficient to trigger an alarm, a new
alarm will be created.
Operator access to Remove alarm

You must have sufficient rights to inhibit alarms in order to remove alarms. If you do not have the right to
inhibit alarms , you cannot remove alarms and the Remove alarm option in the Actions tab of the Active Alarms form will be inaccessible.
The right to remove an alarm - and the Remove alarm… item in the Actions menu - only exists if the system engineer has selected Allow user to remove alarms under the Alarm settings group in the
Alarm tab of the System Configuration form.

1.6 Hiding Alarms
Hiding Alarms
You can hide selected alarms from the Active Alarm form, removing the alarms from view in the Active
Alarms list. Hidden alarms are still active and must still be acknowledged.
Only active alarms can be hidden. Active Events, Event and Alarm Log entries cannot be hidden.
You can hide individual alarms or select multiple alarms and hide them. Hiding alarms augment any
applied filters and you can create filters that will reveal hidden alarms. You must still select to display hidden alarms in order to see them in the Active Alarm form.
Hidden alarms distributed globally and are hidden for all operators on all stations.

Enable Hide Alarms
Operator access to hiding alarms must be enabled in the System Configuration form. If not enabled, the
Hide Alarm menu options will be inaccessible and you will not be able to hide alarms.

When you hide an alarm, the caption HIDDEN ALARMS will be displayed in
the Active Alarms form title to indicate there are hidden alarms in the
Active Alarms form.
You can also disable the ability to hide alarms from all operators, instantly displaying all hidden alarms to
all operators on all operator stations by editing the alarm settings in the System Configuration form.

Displaying hidden alarms in the Active Alarms form
Hidden alarms are not displayed in the Active Alarms form, but you can change the view settings of the
local Active Alarms form to in order to display hidden alarms as well.
Hidden alarms are displayed in italics in the Active Alarms form. The hidden alarms are still registered as
being hidden and are not displayed in the Active Alarms form on other operator stations unless their view
settings are changed as well.
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You can reveal one or more alarms in the active alarms list, removing the hidden status of the alarms and
displaying the selected alarms once more in the Active Alarm form.
There is a difference between revealing selected alarms and displaying all hidden alarms.
Revealing selected alarms allows you to remove the hidden status of a few alarms, causing these alarms to
be visible to all operator on all stations. Displaying all hidden alarms through the View menu of the Active
Alarms form only displays all hidden alarms to the operator of the local operator station and not all other
operators and does not change the hidden status of the alarm.
Finally, you can disable the ability to hide alarms from all operators, instantly displaying all hidden alarms
to all operators on all operator stations by editing the alarm settings in the System Configuration form.

Audit Trial logging of Hide actions
The Audit Trail subtype HideAlarm is used to indicate the Hide Alarm action for an IGSS user.
If the Audit Trail module is enabled, any alarms hidden by operators will result in the user action being
logged in the Audit Trail database.

User Administration and hiding alarms
The user right to hide alarms for specific objects is part of the Can Acknowledge permission for objectlevel protection. Object-level protection permission settings are set up the Definition module as part of
the general set up of the IGSS User Administration module.
If you do not utilize IGSS User Administration or if Object-level protection is not used, then all operators
(users) may hide and reveal alarms for all objects.

Embedded Alarm lists and hidden alarms
Hidden alarms are not displayed in Embedded Alarm lists in the Supervise module and there are no
options to display hidden alarms in Embedded Alarm lists.
If you want to view individual hidden alarms or to display all hidden alarms, you must use the Active
Alarms form and not any Embedded Alarm lists.
See Also

"Enable / Disable Hide Alarms" on page 39
"Hide one or more alarms " on page 41
"Revealing one or more hidden alarms" on page 41
"Displaying all hidden alarms" on page 42

Enable / Disable Hide Alarms
The ability to hide and display hidden alarms is by default disabled for the IGSS configuration and must be
enabled in order to hide alarms from the active alarm list.
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When you enable operators hiding alarms, the Hide Alarms menu options in the Active Alarms form will
become accessible to all operators on all operator stations connecting to the configuration.
To enable Hide Alarms

Make sure the IGSS Master is in Design Mode. If the IGSS Master is in Runtime mode, you can change
modes by clicking Application Menu > Design mode in the IGSS Master .

1. In the IGSS Master, click Design and Setup tab> System Configuration button to open
the System Configuration form.
2. In the System Configuration form > Alarm tab, select the Allow "Hide Alarms" check
box.
3. Click File > Save Project to save the configuration setup and close the System Configuration form.
4. In the IGSS Master dialog, click Yes to restart the configuration in order to apply the new
changes to the configuration.

Disable Hide Alarms
When you disable the operator ability to hide alarms, the Hide Alarms menu options in the Active
Alarms form will become inaccessible to all operators on all operator stations connecting to the configuration.
If hidden alarms exist in the Active Alarms form and you afterwards disable the Hide Alarms, all hidden
alarms will become visible.
To disable Hide Alarms

Make sure the IGSS Master is in Design Mode. If the IGSS Master is in Runtime mode, you can change
modes by clicking Application Menu > Design mode in the IGSS Master .

1. In the IGSS Master, click Design and Setup tab> System Configuration button to open
the System Configuration form.
2. In the System Configuration form > Alarm tab, clear the Allow "Hide Alarms" check box.
3. Click File > Save Project to save the configuration setup and close the System Configuration form.
4. In the IGSS Master dialog, click Yes to restart the configuration in order to apply the new
changes to the configuration.

See Also

Hiding Alarms
"Hide one or more alarms " on page 41
"Revealing one or more hidden alarms" on page 41
"Displaying all hidden alarms" on page 42
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Hide one or more alarms
You can hide one or more alarms in the Active Alarms form, removing them from view but still leaving the
alarms as active.
To hide one or more alarms

1. In the left pane of the Active Alarmsform, select the Active Alarms folder or a select a filter
in the Active Alarms folder to display active alarms in the right pane of the Active Alarms
form (the active alarms list)
2. In the right pane of the Active Alarms form, select an alarm right-click and select Hide
Alarm.
To hide multiple alarms, select the alarms you want to hide in the active alarm list, right click
the selection and select Hide Alarms.
You can also click Actions > Hide Alarms instead of right-clicking the alarm selection to hide
the selected alarms.

3. The selected alarms will not be displayed in the active alarm list but are still active.
4. The title of the Active Alarms form change to include the text HIDDEN ALARMS to indicate
there are hidden alarms in the active alarm list.

See Also

Hiding Alarms
"Enable / Disable Hide Alarms" on page 39
"Revealing one or more hidden alarms" on page 41
"Displaying all hidden alarms" on page 42

Revealing one or more hidden alarms
You can reveal one or more alarms in the active alarms list, removing the hidden status of the alarms and
displaying the selected alarms once more in the Active Alarm form.
To reveal one or more hidden alarms

1. In the Active Alarms form, click View > Show Hidden Alarms to display all hidden alarms
in the active alarm list.
2. In the left pane of the Active Alarmsform, select the Active Alarms folder or a select a filter
in the Active Alarms folder to display active alarms in the right pane of the Active Alarms
form (the Active Alarms list)
3. In the right pane of the Active Alarms form, select the hidden alarm you want to reveal, rightclick and select Hide Alarm. Hidden alarms are displayed in italics in the active alarms list.
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To reveal multiple alarms, select the alarms you want to reveal in the active alarm list, right
click the selection and select Hide Alarms.1
You can also click Actions > Hide Alarms instead of right-clicking the alarm selection to
reveal the selected alarms.

4. The selected alarms will be displayed in the active alarm list.
5. If there are no hidden alarms left in the Active Alarm form, the HIDDEN ALARMS text in the
title of the Active Alarms form will be removed. If there are still hidden alarms, the
HIDDEN ALARMS text will remain in the Active Alarms form title.

1All selected alarms must be hidden or the

Hide Alarms menu option will not be accessible.

See Also

Hiding Alarms
"Enable / Disable Hide Alarms" on page 39
"Hide one or more alarms " on page 41
"Displaying all hidden alarms" on page 42

Displaying all hidden alarms
You can display all hidden alarms in the Active Alarms form by clicking View > Show Hidden Alarms
in the Active Alarms form.
All hidden alarms will be displayed in italics in the active alarm list (right pane of the Active Alarms form)
for the local operator station only. The status of the hidden alarms is not changed. They are still registered
as hidden alarms and are still hidden on all other operator stations.
To remove the display setting for all hidden alarms, click View > Show Hidden Alarms. The Show Hidden Alarms view option will be cleared and the hidden alarms no longer displayed in the form.
See Also

Hiding Alarms
"Enable / Disable Hide Alarms" on page 39
"Hide one or more alarms " on page 41
"Revealing one or more hidden alarms" on page 41
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1.7 Alarm Instructions and Notes
View the operator instruction
You can view an instruction for a given alarm registered in the alarm list or the alarm log, provided that an
operator instruction has been specified by the development engineer during system design.

Procedure

1. In the alarm list or alarm log, click on the alarm whose operator note you wish to display.
2. In the function menu, select Actions → Note.
3. The dialogue which appears on the screen provides two tabs:
4. Select Alarm Text to display the predefined instructions to the operator.

Shortcut

1. You are inside the list and a message line is selected.
2. Click the right mouse button.
3. This opens the Actions function box and places it immediately next to the selected message so that you can now conveniently activate the Note command, and open the Alarm Text tab.

See also

Write an alarm note

Background information
You can enter your own comments about an alarm situation. This may be useful if you wish to inform your
colleagues, possibly the operator of the next shift, how you have dealt with the situation and which measures you have taken to eliminate the problem.

Procedure

1. With the mouse, select the alarm in the Acrtive Alarms list for which you wish to write a comment.
2. Right click on the alarm and select Note… or go to the Actions menu and select Note.
3. The dialogue which appears on the screen displays two tabs:
4. Select Alarm Note.
5. The text field underneath the Alarm Note tab is where you can enter your text.
6. After you finish entering your textSave with.
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l

Click on

if you wish to print out your comment together with alarm information.

See also

1.8 Updating and Freezing the Alarm List
Update the list
Background information
The process values shown in the Alarm List and Event List are not continuously refreshed. They are
updated whenever the Worst Value of the object value has changed, or at specific intervals set by the
System Integrator during system design. IGSS therefore provides an Update facility so you can read and
load the newest process values whenever needed.

Procedure

1. In the Tree View, select the list you wish to update.
2. Move into the selected list in the right-hand section of the screen.
3. In the Tool Menu, click Actions > Update.
4. The entire list is updated.

l

For the options of the Actions menu to become available, you must have moved the cursor out of the Tree View into the
alarm list or alarm log !

Shortcut

1. You are inside the list.
2. Simply click the right mouse button.
3. This opens the Actions function box so that you can now conveniently activate the Update function.

See also

Freeze the list

Background information
In situations where you have a cluster of alarms in rapid succession it might be useful to freeze the list for
a short period at its current status. The freeze period is predefined by the development engineer during
system design and cannot be changed by the operator.
Default setting: 30 seconds
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Procedure

1. In the Tree View, select the list you wish to freeze.
2. Move into the selected list in the right-hand section of the screen.
3. In the Actions menu, select Freeze.

l

For the options of the Actions menu to become available, you must have moved the cursor out of the Tree View into the
Alarm List or the Event List.

Shortcut

1. You are inside the list and a message line is selected.
2. Click the right mouse button.
3. This opens the Actions function box so that you can now conveniently activate the Freeze function.

l

A seconds counter in the screen title bar indicates the ‘frozen’ status and the number of seconds still to go.

See also

1.9 Customizing, Sorting and Filtering
Filter the Alarm list
Filter the Active Alarms form
Alarms are displayed as they are received in the Active Alarms form, which can contain many alarm
records, quickly becoming difficult to gain an overview. While you can sort the alarms in the columns, it
may be difficult to gain an overview of all alarms that satisfy specific criteria, such as all alarms from a specific area, or high priority all alarms from specific objects.
You can create and apply a filter to only display alarm records in the right-panes of the Active Alarms
form that meet the filter criteria.
Filters can be created for Active alarms and Active Events as well as alarms and events that have been
saved in the respective logs (Alarm log and/or Event log).
When you create a new filter and apply it to the Active Alarms form, the name of the selected filter will
be displayed in the title of the Active Alarms form to indicate that the alarm list is the product of an
applied filter.
Filters are saved locally on the machine and are available to all operators who use the IGSS configuration on the local machine.
Default Filters

You can define a filter to be the default filter for the Active Alarms, Active Events, Alarm Log and Event Log
each. A default filter will be applied automatically when opening (clicking on ) the respective list (Active
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Alarms, Active Events, Alarm Log and Event Log) in the left pane of the Active Alarms form.
The procedure to define and create default filters differ between the Active Alarm and Event list and Alarm
and Event Log list. Active Alarm and Event list filters are created and defined in one way and Alarm and
Event Log list filters are created and defined in another fashion.
Mobile Filters

The IGSS Mobile application uses existing filters to sort and display records on the operator smartphone.
By default, filters are also accessible to IGSS Mobile users , but you can create special filters only for
mobile user and filter only for operator station users by adjusting the special filter parameters.
Special filter parameters

When you create a filter, you can apply special filter parameters, locking the filter from editing, making the
filter globally available to all operator stations, making the filter available to IGSS Mobile users, requiring
the operator to input a date interval for the filter when it is applied as well as adding special Alarm report
based columns to the Active Alarm list when the filter is applied and restricting operator use of the alarm filter.
See Also

"Define a new filter" on page 91
"Edit an existing filter" on page 92
"Delete an existing filter" on page 93
"Define special filter parameters" on page 93
"Set a default Active Alarms or Active Events list filter" on page 95
"Set a default Alarm log or Event log filter" on page 96
Define a new filter
You can create a filter to reduce the records displayed in the list panes of the Active Alarms form to only
those records that meet the filter criteria.

To create a new filter

1. In the left pane of the Active Alarms form, select the record type to be displayed: Active
Alarms, Alarm log, Active Events or Event log. The new filter will only be applied to the selected
display type.
2. Click Customize > New Filter to open the Defining Filters form. You can also click the New
Filter button in the toolbar to open the Defining Filters form.
3. In the Filter name field on the Defining Filters form, enter a filter name.
The filter name is not required to be unique and it is possible to create identical filter names. It
is recommended to create unique filter names to better distinguish filters from each other.
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4. In the Edit Condition group:
1. In the Property field, select the filter property from the drop down list.
2. In the Condition field, select the filter condition of the property from the drop down
list. The displayed properties depend on the selected property.
3. In the Value field, select the filter value from the drop down list. The filter value will
be applied to the condition.
5. Click the Add button to submit the filter condition to the filter.
6. If you need to create successive filter conditions, select a logical operator to apply to the next filter condition (And / Or) and repeat steps 4 and 5 above.
7. Click the OK button to save the filter and close the Defining Filters form.

A filter can only contain a maximum of 10 filter criteria.
See Also

"Filter the Active Alarms form " on page 45
"Multiple alarm filter conditions" on page 47
"Edit an existing filter" on page 92
"Delete an existing filter" on page 93
"Define special filter parameters" on page 93

Multiple alarm filter conditions
You can define up to 10 filter conditions for an alarm filter.
If you require additional filter conditions, you can specify more filter conditions in an array of conditions,
using semi-colons (;) to separate each filter condition.
Only the following filter conditions can be arrayed:
l

Begins with

l

Is Exact

l

Match

The arrayed filter conditions can be applied to any alarm filter condition property that uses texts such as
l

Object Name

l

Object Description

l

Area Name

l

Alarm Text
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l

Alarm State

l

User

Maximum length of the array
The array can contain a maximum of 128 characters, including the semi-colon separators.

Semi-colons as text
If the text you want to filter contains a semi-colon, you must use a double semi-colon (;;) to represent the
semi-colon as a text instead of a semi-colon as a separator.

Example of an arrayed filter condition
An alarm filter is created to display the following objects:
l

A01

l

A02

l

A03

l

A04

l

A05

l

A06

l

A07

l

A08

l

A09

l

A10

l

A11

Since there are 11 objects and the alarm filter conditions only can process 10 conditions, the following filter
condition is created:
l

Alarm filter condition property: Object Name

l

Alarm filter condition: is exact

l

Value: A01; A02; A03; A04; A05; A06; A07; A08; A09; A10; A11

See Also

"Filter Conditions " on page 48
Filter Conditions
The following filter conditions can be used in the Condition field on the Defining Filters form.

Condition

on

Property

Acknowledge Date,
Begin Date, End Date,
Arrival date

Use this filter condition to...

define the exact date to the filter.
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Condition

between

yesterday

Property

Acknowledge Date,
Begin Date, End Date,
Arrival date

Acknowledge Date,
Begin Date, End Date,
Arrival date

Use this filter condition to...

set a time period to the filter, defining the start date and time and end
date and time.
filter the alarms using yesterday's
date.
The machine date is used to determine the present date.
filter the alarms using present date.

today

Acknowledge Date,
Begin Date, End Date,
Arrival date

in the last

Acknowledge Date,
Begin Date, End Date,
Arrival date

define a number days from the
present date to apply to the filter.

is not
blank

Acknowledge Date,
Begin Date, End Date,
Arrival date

apply dates that are not empty to the
filter.

is blank

Acknowledge Date,
Begin Date, End Date,
Arrival date

apply dates that are empty to the filter.

greater
than

Worst Value, Priority,
Alarm No, Value, Driver
ID, Node ID

define a value which the selected
property must be greater than to
apply to the filter.

less than

Worst Value, Priority,
Alarm No, Value, Driver
ID, Node ID

define a value which the selected
property must be less than to apply
to the filter.

equal to

Worst Value, Priority,
Alarm No, Value, Driver
ID, Node ID

define a value which the selected
property must be equal to for the filter.

not equal
to

Worst Value, Priority,
Alarm No, Value, Driver
ID, Node ID

define a value which the selected
property must not be equal to for the
filter.

in
between

Worst Value, Priority,
Alarm No, Value, Driver
ID, Node ID

set an interval to apply to the filter,
defining a lower and upper value.

Begins
with

Object Name,
Object Description,
Alarm Name, Alarm
Text, Alarm State, User

define the beginning characters
which the property must be equal to
for the filter. The filter condition is
case sensitive.

Is exact

Object Name,

define the exact name of the prop-

The machine date is used to determine the present date.
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Condition

Property

Object Description,
Alarm Name, Alarm
Text, Alarm State, User

Use this filter condition to...

erty to for the filter. The filter condition is case sensitive.
use wildcards to define parts of the
property name for the filter where
l

l

* matches any number of
characters
? matches any single character

Example:
Given the three objects:

Match

Object Name,
Object Description,
Alarm Name, Alarm
Text, Alarm State, User

l

Tr01

l

Tu01

l

Tr02

The different Match filter condition
values will result in the following:
l

l

l

"Tr*" will find Tr01 and Tr02
but not Tu01
"T?01" will find Tr01 and Tu01
but not Tr02
"T?0*" will find Tr01, Tr02
and Tu01

The filter condition is case sensitive.

Is True

Maintenance Alarm, Has
alarm note, Hidden
alarm

select only the alarms that are maintenance alarms, hidden alarms or
contain an alarm note.

Is False

Maintenance Alarm, Has
alarm note, Hidden
alarm

select only the alarms that are not
maintenance alarms, hidden alarms
or do not contain an alarm note.

See Also

"Filter conditions, examples" on page 51
"Filter the Active Alarms form " on page 45
"Define a new filter" on page 91
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Filter conditions, examples
You can combine many different filter conditions in the filter to create complex filter conditions, connecting
the conditions with the AND / OR logical operators.
The following are examples of user applied sample filter conditions

To filter unacknowledged alarms
Filter Conditions: Acknowledge Date Is blank

To filter active alarms
Filter Conditions: End Date Is blank

To filter active alarms that are also unacknowledged
Filter Conditions: Acknowledge Date Is blank AND End Date Is blank.

To filter active, high priority (priority over 100) alarms
Filter Conditions: (End Date Is blank AND Priority greater than 100)

To filter active alarms and unacknowledged maintenance alarms
Filter Conditions: End Date Is blank OR (Maintenance alarm Is True AND Acknowledge Data Is blank)

To filter acknowledged maintenance alarms
Filter Conditions: Maintenance alarm Is True AND Acknowledge Data Is not blank

To filter all active hidden alarms
Filter Conditions: Hidden Alarm Is True AND End Date Is blank
(You must set the alarm form to display hidden alarms in order to be able to see hidden alarms)

See Also

"Filter Conditions " on page 48
"Filter the Active Alarms form " on page 45
"Define a new filter" on page 91
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Edit an existing filter
You can edit existing filters, adding new filter conditions, deleting or adjusting existing conditions.
Some filters have been write-protected to disable editing. If this is the case, you must have sufficient
user rights to edit a write-protected filter. User rights are determined by the User Group you are member of in the IGSS User Administration module.

To edit an existing filter

1. In the left pane of the Active Alarms form, select the record type to be displayed: Active
Alarms, Alarm log, Active Events or Event log.
2. Click Customize > Edit Filter to open the Defining Filters form. You can also click the Edit
Filter button in the toolbar to open the Defining Filters form.
3. To rename the filter, enter a new filter name in the Filter name field on the Defining Filters
form.
The filter name is not required to be unique and it is possible to create identical filter names. It
is recommended to create unique filter names to better distinguish filters from each other.

4. To edit an existing condition, select the filter condition you want to edit in the Filter Conditions group.
1.

In the Edit Condition group:

2. In the Property field, select a new filter property from the drop down list.
3. In the Condition field, select a new filter condition of the property from the drop
down list. The displayed properties depend on the selected property.
4. In the Value field, select a new filter value from the drop down list. The filter value
will be applied to the condition.
5. To delete an existing condition, select the filter condition you want to edit in the Filter Conditions group and click the Delete button.
6. To add a new Filter condition,
1. In the Property field, select the filter property from the drop down list.
2. In the Condition field, select the filter condition of the property from the drop down
list. The displayed properties depend on the selected property.
3. In the Value field, select the filter value from the drop down list. The filter value will
be applied to the condition.
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4. Select the relevant logical operator to apply to the new filter condition.
5. Click the Add button to submit the filter condition to the filter.
7. Click the OK button to save the filter and close the Defining Filters form.

See Also

"Filter the Active Alarms form " on page 45
"Define a new filter" on page 91
"Delete an existing filter" on page 93
"Define special filter parameters" on page 93
Delete an existing filter
You can delete an existing filters from the local machine, removing it from the Active Alarms forms.
Deleting a filter does not require user confirmation and will be removed immediately. A deleted filters can
not be restored and you must recreate the filter if you regret deleting the filter.

Filters are saved locally on the machine and are available to all operators who use the IGSS configuration on the local machine. If you delete a filter, you will remove access to the filter for all operators that use the machine.

To delete a filter

1. In the left pane of the Active Alarms form, select the record type to be displayed: Active
Alarms, Alarm log, Active Events or Event log. The new filter will only be applied to the selected
display type.
2. Click Customize > Delete Filter to delete the filter. You can also click the Delete Filter button in the toolbar to delete the filter.
There is no user confirmation dialog to confirm the removal of the filter.

See Also

"Define a new filter" on page 91
"Edit an existing filter" on page 92
"Define special filter parameters" on page 93
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Define special filter parameters
You can apply the following parameters to an existing filter to change the characteristics of the filter, specializing the filter in some cases and expanding the filter functionality in others.
All parameters can be combined with each other.

Create a Global filter
All filters are by default local filters and are saved on the local machine. A filter defined by one operator station will not be accessible to other users on other operator stations.
You can make a filter global across the IGSS configuration by selecting the Global check box in the Defining Filters form when creating or editing a filter.
A global filter is saved in the IGSS configuration and distributed to all online stations when they connect to
the IGSS server. Global filters are also synchronized between IGSS servers in a dualized (hot standby)
IGSS server environment.
Global alarm filters can be assigned to the selected alarm printer for the station in the System Configuration form > Reports tab > Alarm group to only print alarms that satisfy the global filter conditions.

Create a Write-protected filter
By default, any operator can edit or delete a filter, as well as create a new filter. You can prevent operator
from editing a filter by protecting the individual filter. When you protect a filter, only operators that are
IGSS users and have access to the Can use System Commands global rights may edit a protected filter.
Write-protecting a filter therefore requires the IGSS User Administration module is enabled, set up and in
use on the IGSS configuration.
You can write protect a filter by selecting the Protect check box in the Defining Filters form when creating or editing a filter.
You can combine the Write Protected filter with the User limited filter for additional filter protection.

Create a filter which prompts for a filter period
By default, the filter is applied to all records in the active alarm list, active event list, alarm log or event
log regardless of start or end date and time.
You can create a filter which requires the user to enter the start date and time and the end date and time of
the alarm or event before applying the filter to the event or log list.
Select the Prompt for Period check box in the Defining Filters form when creating or editing a filter to
create a period-defined filter that can apply user input for start and end dates.

Create a user limited (Exclusive) filter
A user limited (Exclusive) filter is a filter which only certain IGSS users may apply to the log list or event
list. Any operator can apply any log or list filter by default, but you can prevent a filter from being applied
by users who do not have sufficient rights by using the Exclusive parameter on the filters.
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The IGSS User Administration module must be enabled, set up and in use on the IGSS configuration
and the Exclusive parameter must be applied to at least one filter to enable user limited filters.
If the IGSS User Administration module is enabled and the Exclusive parameter applied to at least
one filter, then only the users with the Can Administer Global Right may apply any filter. Users without
the Can Administer global right can only apply filters that have the Exclusive check box selected.
The Exclusive parameter is applied to a filter by selecting the Exclusive check box in the Defining Filters form when creating or editing a filter.
You can combine the User limited filter with the Write Protected filter for additional filter protection.

Create an Alarm Report filter
The Alarm Report contains additional alarm statistics when printed which the active alarm list does not display.
You can set up the active alarm list to display the additional alarm statistics from the Alarm Report by
selecting the Format as 'alarm print' check box in the Defining Filters form.
The following columns are displayed in the Active Alarm list:
l

The object value when the alarm was started

l

The object value when the alarm was acknowledged

l

The object value when the alarm was ended

Remove an IGSS Mobile filter
By default, all filters are enabled by be used by IGSS Mobile users. You can remove access to the filter
from IGSS Mobile Users by clearing the Include in IGSS Mobile check box in the Defining Filters form.
See Also

"Define a new filter" on page 91
"Edit an existing filter" on page 92
"Direct alarm message printing" on page 73
Set a default Active Alarms or Active Events list filter
You can set a specific list filter as the default list filter. The default filter will be applied to the active alarm
list or Active Events when you open the Alarm Module.
In a multi-user environment, this setting only applies to the machine on which it is set. The default list filter can therefore not be uploaded to the IGSS server and distributed to the other operator stations.

- 55 -

IGSS V13, User Guide

To set a default active alarm list filter

1. In the upper left pane of the Active Alarms form, navigate to the filter you want to make the
default filter in the Active Alarms node.
2. Click Customize > Set as Default Filter to make the selected filter the default filter for the
Active Alarm list. You can also click the Set as Default Filter button in the toolbar.

To set a default Event list filter

1. In the lower left pane of the Active Alarms form, navigate to the filter you want to make the
default filter in the Active Events node.
2. Click Customize > Set as Default Filter to make the selected filter the default filter for the
Active Events list. You can also click the Set as Default Filter button in the toolbar.

See Also

"Define a new filter" on page 91
"Set a default Alarm log or Event log filter" on page 96
Set a default Alarm log or Event log filter
If the alarm or event log contains records that exceed the user-defined maximum alarm or event log limit,
the latest alarm or event logs will be displayed. To find older alarm or event logs, you must create and
apply an alarm or event log filter to display the desired alarm or event log entries.
You can create a default log filter which will automatically filter the log list when you click the respective
folder (Alarm log or Event log) in the lower left pane of the Active Alarms form.
Creating a default log list filter is different than creating an Active Alarm list filter or Active Event list filter.
To create a default log list filter, you must create an log list filter and prefix the filter name with an asterisk
(*)
For example, if you create an alarm log filter called "Pump alarms ", you can set the filter as the default
Alarm log list filter by changing the name of the filter to "*pump alarms".

Multiple default log filters
You can only apply one default Alarm log list filter and one Event log list filter although you can define
many log list filters with a prefixed asterisk in the filter name.
The default log list filter is sorted alphabetically and the first appearing filter with a prefixed asterisk will be
applied as the default log list filter.
For example, there are two log list filters defined: *Afilter and *Bfilter. The log list filter named *Afilter will
be applied as the default log list filter as it comes before *Bfilter when sorted alphabetically.
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See Also

"Define a new filter" on page 91
"Set a default Active Alarms or Active Events list filter" on page 95

The Alarm List format
Create a new Alarm List Format
You can change the physical appearance of the Alarm or Event list, adding columns to the list and removing
columns from the list. As each column displays alarm or event information, you can define how much information the alarm or event list is to display to the operators.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.
You can create a new Alarm List Format to save the column layout of the alarm list or event list in the alarm
list format and applying the Alarm List Format to the alarm list or event list.
Once an new Alarm List Format has been created, other operators can also apply the format to the alarm
list or event list by selecting the format.
Alarm List Formats are available to all IGSS users and can be applied by any IGSS user of the configuration.
The Alarm List Format is specific to the IGSS configuration on the local machine and cannot be distributed
to other machines or IGSS configurations.

To create a new Alarm List Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Alarm List Format form, click the New button to open the New Format dialog and
enter a format name. The format name is not required to be unique and it is possible to create
identical format names. It is recommended to create unique names to better distinguish formats
from each other.
4. In the Formats group (lower part of the Alarm List Format form), make sure the new alarm
list format is selected.
5. In the upper part of the Alarm List Format form, you can:
l

Rearrange the order of the columns

l

Add new columns to the columns displayed

l

Remove existing columns from the columns displayed

l

Change the column header name

l

Change the column width
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6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Apply an Alarm List Format to the Active Alarms form" on page 98
"Delete an Alarm List Format" on page 99
"Rearrange the columns" on page 100
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
"Rename a column" on page 101

Apply an Alarm List Format to the Active Alarms form
You can apply an existing Alarm List Format to the Active Alarms form, changing the layout and appearance of the columns in the Alarm list, event list, alarm log list and the event log list. only one Alarm List
Format can be applied to the Active Alarms form at a time.
Alarm List Formats are applied to all users and cannot differentiate between IGSS users.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To apply a new Alarm list Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to apply. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Delete an Alarm List Format" on page 99
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Edit an Alarm List Format
You can edit an existing Alarm List Format, changing the column layout, order and header names.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To edit an Alarm List Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the upper part of the Alarm List Format form, you can:
l

Rearrange the order of the columns

l

Add new columns to the columns displayed

l

Remove existing columns from the columns displayed

l

Change the column header name

l

Change the column width

5. Click the Save button to save the column layout to the new Alarm List Format.
6. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Apply an Alarm List Format to the Active Alarms form" on page 98
"Delete an Alarm List Format" on page 99
"Rearrange the columns" on page 100
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
"Rename a column" on page 101
Delete an Alarm List Format
You can delete an Alarm List Format, removing it from the list of formats.
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The alarm list format can be applied to the Event list, Event log and Alarm log as well.
Once a format has been deleted, it cannot be restored. You must recreate it
again if you want to apply the format to the Active Alarms form.

To delete an Alarm List Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to delete. The upper part of the Alarm List Format form, will change, reflecting the column layout options for the selected Alarm List Format.
4. Click the Delete button to delete the selected alarm list format
5. Click the OK button to close the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Apply an Alarm List Format to the Active Alarms form" on page 98

Change the list format
Rearrange the columns
The columns in the Active Alarms list are displayed in the order listed in the Alarm List Format form. You
can change the order of the displayed columns in the Active Alarms form by editing the column properties in the Alarm List Format applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To rearrange the columns in the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
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4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select a column and use the Move Up and Move Down buttons to rearrange the order of
the column will be displayed in the Active Alarms form.
5. Click the Save button to save the column layout to the new Alarm List Format.
6. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Rename a column" on page 101
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
Rename a column
You can rename a column header, changing the title of the column as it is displayed in the Active Alarms
form by editing the Alarm List Format applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To rename a column header in the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to change the header of
5. In the Change Column Name field enter the new column header to be displayed in the Active
Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
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Rearrange the columns
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
Remove columns
The columns in the Active Alarms list are displayed in the order listed in the Alarm List Format form. You
can remove columns from the Active Alarms form by editing the column properties in the Alarm List
Format applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To remove a column from the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to remove.
5. Click the Remove button to remove the selected column from the Active Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Rename a column" on page 101
"Add columns" on page 102
"Change the column width" on page 103

Directly in the list
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1. Click on the right-hand limiting line of the column you wish to remove, using the left mouse button and keep the
mouse button pressed.
2. The cursor changes its shape to a cross and highlights the vertical column delimiter.
3. Keep the left mouse button depressed and drag the cursor to the left until the right line covers the left line. In
this way, the width of the column has been reduced to nothing and the column is removed from the list.

Only a column which was removed (collapsed) directly in the list by dragging its right-hand limiting line to the left until clearance,
can be retrieved again directly in the list, without using menu functions.
The first method of removing columns is the more permanent layout change. It can only be undone by using the ADD button in the
Configure Columns dialogue.

Add columns
The columns in the Active Alarms list are displayed in the order listed in the Alarm List Format form. You
can add columns from the Active Alarms form by editing the column properties in the Alarm List Format
applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To remove a column from the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to add.
5. Click the Add button to add the selected column to the Active Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Rename a column" on page 101
"Remove columns" on page 101
"Change the column width" on page 103

- 63 -

IGSS V13, User Guide

Directly in the list
Place the crosshair cursor onto the limiting line of the collapsed column and drag it to the right until the
retrieved column has reached the width required.

Change the column width
You can change the column width as it is displayed in the Active Alarms form by editing the Alarm List
Format applied to the Active Alarms form or directly in the Active Alarms list.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.
To change a column width by editing the format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to change the width of
5. In the Width field enter the new column width of the column (expressed in pixels) displayed in
the Active Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

To change a column width directly in the Active Alarms list

1. Left-click on the right-hand edge of the column whose size you wish to reduce or widen and keep
the mouse button pressed.
2. The cursor changes its shape to a cross and highlights the vertical column delimiting line.
3. Maintaining the left mouse button depressed, drag the line to the left or to the right.
4. Release the mouse button as soon as you have obtained the required column width.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Rename a column" on page 101
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"Remove columns" on page 101
"Add columns" on page 102

The default Alarm List format
The default List or Sort Format
IGSS contains a system default for the Alarm List format and the Sort Order formats. The system default
formats are saved on the local machine of the operator station and can be restored to the Active Alarms
form by the operator if necessary. You can see the contents of the system default list format in the
See Also section below.

Changing the System Default List Format
You can also update the system default formats from the Active Alarms form if you want to use another
default format than the original system default. The alarm list format presently in use is saved as the system default, automatically updating the system default. Once the system default has been updated or
changed, you cannot restore the original system default format again.

The option to save a format as the system default is normally not accessible to users and must be
enabled by a System Designer with administrator rights on the local machine.

See Also

" The system default List format" on page 105

The system default List format
The Alarm List or Alarm Log contains by default the following information in the order shown:

l

S.No. = Sequence Number

l

Start Date

l

Start Time

l

Acknowledge Time

l

End Time

l

Object Name

l

Worst Value

l

Alarm Text

l

Area Name

l

Object Description

l

Value

l

Priority
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l

Alarm Number

l

Acknowledge Date

l

End Date

l

Alarm State

l

Driver Id.

l

Node Id.

l

User name

l

The Icons

Restore the Alarm list default format
You can restore the alarm list format to the system default, restoring all the columns selected for display,
column rankings, column header names and column widths with the column layout from the system default
format.

To restore the system default alarm list format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to restore the system default layout for. The upper part of the Alarm List
Format form, will change, reflecting the column layout options for the selected Alarm List
Format.
4. Click the Default button to insert the system default column layout into the selected alarm list
format. The upper part of the Alarm List Format form, will change, displaying the system
default column layout for the selected Alarm List Format.
5. Click the OK button to apply the alarm list format and close the Active Alarms form.

You can update the system default list format, creating your own column layout as the system default.
See Also

" The system default List format" on page 105
"Update the System default alarm list format" on page 106
Update the System default alarm list format
The column layout in the system default Alarm List Format can changed, creating your own column layout
as the system default. The new column layout will be applied to the selected Alarm List Format every time
the Default button in the Alarm List Format form is clicked to restore the default column layout.
The System Default Alarm List Format is specific to the configuration on the local machine and cannot be
distributed to other machines or configurations.
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Once you have changed the system default Alarm List Format, you cannot
restore it. The changes become the new system default.
By default, the menu option to update the system default Alarm List Format is disabled and must be
enabled in order to update the system default.

Enable update of system default Alarm List Format update using the registry editor (This station only)
To enable updating system default Alarm List Format for all configuration operators on the local machine.

1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the
search field of the Windows Start menu.
2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V13.00.00\Alarm32_HKLM, right-click on the allow save default key and select
Modify.
3. In the Value Data field of the Edit DWORD (32-bit) Value form, enter "1" and click OK to
save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

Enable update of system default Alarm List Format update using the Configuration database
(other stations)
You can use the Configuration database to enable this operator station or other IGSS stations update the
system default Alarm List Format.
Microsoft Access must be installed on the machine in order to edit the configuration database.

1. On the local machine, start the Microsoft Access program and open the configuration database
found in the configuration folder.
2. In Tables pane of Microsoft Access, double-click the RegSettings table to open the RegSettings table in the right pane of Microsoft Access.
3. In the ValueName column, find the allow save default key for the IGSS station you want to
edit. The station identification is visible in the Path column and is expressed as StationA, StationB and so on.
4. In the Value column, enter "1" to enable updating the system default Alarm List Format for the
selected IGSS station.
5. Click Ctrl+S to save the changes and click File > Exit to close the Microsoft Access program.

You can find a list of the Station identification and the station name in the
registry key HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V13.00.00\CommDrv_HKLM\StationDatabase folder. The Stationno key is the station identification and the value in the Stationno key
is the station name as it is defined in the Configuration tab of the System Configuration form.
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See Also

"Save the list format as the default format" on page 108

Save the list format as the default format
When updating the system default Alarm List format, the Alarm List Format presently applied to the Active
Alarms form is used. You can save the Alarm List Format as the system default Alarm List Format, effectively updating the system default.
By default, the menu option to update the system default Alarm List Format is disabled and must be
enabled in order to update the system default.
To update the system default Alarm List Format you must:

1. Apply a the Alarm list Format you want to turn into the system default
If the alarm list format you want to use already is applied to the Active Alarms form, you can skip this
step.

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to use. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. Click the OK button to apply the alarm list format to the Active Alarms form.

2. Save the Alarm List Format as the system default
In the Active Alarms form, click Customize > Save as Format Default.
See Also

"Update the System default alarm list format" on page 106
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Sort the Alarm List
Change the sorting order in the list
The alarms or events in the alarm or event list are displayed using the default sort order. You can change
the sort order of the displayed alarms or events, displaying the order which is relevant for your particular
alarm processing, for example sorting the alarms in the list by alarm priority first and then the Alarm start
date.

The sort format can be applied to the Event list, Event log and Alarm log as well.
You can change the sort order in the Alarm list in two ways:
l

Applying a Sort Format to the list

l

Directly on the list

Applying a Sort format to the list
You can apply an existing sort format to the Alarm or event list. A Sort format is a collection of saved sort
order set up, including sorting direction which can be applied to the alarm or event list. Sort formats can be
created, edited and deleted freely by operators but cannot be distributed to other IGSS stations or other
machines.
You can also restore the default sort order from the system by using Sort formats.

Directly in the list
You can change the sorting order directly in the Alarm/Event list or log by clicking on the column title you
wish to use as sorting criterion. The sorting direction will toggle between ascending and descending when
you click the column header, sorting the records in the Alarm/Event list or log.
See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Create a new Sort format
You can create a new Sort format to save the sort order of the alarm or event list in the Sort format and
applying the Sort format to the alarm or event list.
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Once an new Sort format has been created, other operators can also apply the format to the alarm or event
list by selecting the format.
Sort Formats are available to all IGSS users and can be applied by any IGSS user of the configuration.
The Sort Format is specific to the IGSS configuration on the local machine and cannot be distributed to
other machines or IGSS configurations.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To create a new Sort Format

1. Click in the alarm or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Set Sort order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Set Sort Order form, click the New button to open the New Format dialog and enter a
format name. The format name is not required to be unique and it is possible to create identical
format names. It is recommended to create unique names to better distinguish formats from
each other.
4. In the Formats group (lower part of the Sort Order form), make sure the new alarm list format
is selected.
5. In the upper part of the Set Sort Order form, Sort group
1. Select the column you want to change the sort order for and click the Move Upor
Move Down buttons to change the sort order, moving the selected column up or
down the column list.
2. Select the Ascending / Descending options to change the sort direction of the selected column.
6. Select a new column and repeat step 5 until you are satisfied with the new sort order.
7. Click the Save button to save the column layout to the new Sort Format.
8. Click the OK button to apply the new Sort Format to the Active Alarms form.

See Also

"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Apply a Sort Format
You can apply an existing Sort Format to the Active Alarms form, changing the sort order of the records in
the Alarm or event list. Only one sort order can be applied to the Active Alarms form at a time.
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The sort order is applied to all users and cannot differentiate between IGSS users.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To apply a new Sort Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to apply. The upper part of the Set Sort Order form, will change, reflecting the sorting order for
the selected Sort Format.
4. Click the OK button to apply the new sort order to the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Edit a Sort Format
You can edit an existing Sort Format, changing the column layout, order and header names.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To edit a Sort Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to edit. The upper part of the Set Sort Order form, will change, reflecting the sorting order for
the selected Sort Format.
4. In the upper part of the Set Sort Order form, Sort group, select the column you want to
change the sort order for and click the Move Up or Move Down buttons to change the sort
order, moving the selected column up or down the column list.
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5. Select the Ascending / Descending options to change the sort direction of the selected
column.
6. Select a new column and repeat step 5 until you are satisfied with the new sort order.
7. Click the Save button to save the column layout to the selected Sort Format.
8. Click the OK button to apply the new sort format to the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Delete a Sort Format
You can delete an Sort Format, removing it from the list of formats.

The sort format can be applied to the Event list, Event log and Alarm log as well.
Once a format has been deleted, it cannot be restored. You must recreate it
again if you want to apply the format to the Active Alarms form.

To delete an Sort Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to delete. The upper part of the Set Sort Order form, will change, reflecting the sorting order
for the selected Sort Format..
4. Click the Delete button to delete the selected Sort Format
5. Click the OK button to close the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
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"Restore the default Sort Format" on page 112
Restore the default Sort Format
When IGSS is installed, the program already contains a system default sort order already applied to Active
Alarms list. When you create and apply sort formats to the Active Alarms list, the sort order will change to
the new sort order.
You can restore the default sort order to the Active Alarms list by updating a sort format with the default
sort order and then applying the sort format to the Active Alarms list.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To restore the default sort format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to restore the default sort order for. The upper part of the SeetSort Order form, will change,
reflecting the sort order and sorting directions of the columns.
4. Click the Default button to insert the default sort order and sort direction into the selected sort
format. The upper part of the Set Sort Order form, will change, displaying the new sort order.
Format.
5. Click the OK button to apply the sort format and close the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112

1.10 Printing Alarms
Direct alarm message printing
In addition to being displayed in the Active Alarms list, an alarm message can also be sent directly to the
alarm printer whenever the alarm is triggered. The alarm message print will not affect normal alarm processing and the alarm can be acknowledged and processed normally through the Active Alarms form.
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Required setup for direct alarm message printing
An alarm printer must be set up in the System Configuration form > Reports tab > Alarm Printer
group in order to print the alarm messages.
l

l

If the To Printer check box is selected, the alarm message will be sent directly to the alarm
printer and also displayed in the Active Alarms form.
If the To Printer check box is cleared, the alarm message will not be printed and will only be displayed in the Active Alarms form.

Enable alarm print for each alarm

You must also enable sending alarm messages directly to the alarm printer for each alarm number in the To
Printer check box on the Edit Alarm Description form.

The Edit Alarm Description form is found in Supervise > Tools > Alarms > Alarm Details form
> Edit button.

Print only alarms from a global alarm filter
You can also only print alarms that match a global alarm filter by selecting the global alarm filter in the
Match global alarm filter field in the System Configuration form > Reports tab > Alarm Printer
group.
Only one global alarm filter can be selected at a time for the station.
If no filter is selected, all alarms will be passed on to the alarm printer. This is the default setting of the
Match global alarm filter field.

The Alarm Print Format
The direct alarm message print will use the alarm print format as the print format when printing alarms,
either directly or when manually printing the alarm list. The alarm list format presently in use in the Active
Alarms form is not used to print alarm details.
You can update the alarm print format with the present alarm list format, but only if this is enabled on the
local machine.
See Also

"The Alarm Print Format" on page 75
"Printing the alarm list /alarm log" on page 77
"Define special filter parameters" on page 93
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The Alarm Print Format
The Alarm Print Format is used to determine the layout of the alarm message print and is applied when directly printing alarm messages. The columns to be printed, the order of the columns and the width of the
columns are specified in the Alarm Print Format which is then applied as the print layout.
The Alarm Print Format is specific to the IGSS configuration on the local machine and cannot be distributed
to other machines or IGSS configurations.

Edit the format
By default, the menu option to update the Alarm Print Format is disabled, limiting the Alarm Print Format to
the column layout defined in the system default .
If the menu option to update the Alarm Print Format is enabled, you can change the alarm print format, specifying which alarm list columns to print and in which order they are displayed as well as the column width.
The Alarm Print Format will be overwritten with your changes, but you can restore the system default alarm
print format later if necessary.
You cannot create additional Alarm Print Formats, only edit the existing Alarm Print Format.

Enable Alarm Print Format update using the registry editor (This station only)
To enable updating Alarm Print Format for all configuration operators on the local machine.

1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the
search field of the Windows Start menu.
2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V13.00.00\Alarm32_HKLM, right-click on the allow save alarm print format
key and select Modify.
3. In the Value Data field of the Edit DWORD (32-bit) Value form, enter "1" and click OK to
save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

Enable Alarm Print Format update using the Configuration database (other stations)
You can use the Configuration database to enable this operator station or other IGSS stations update Alarm
Print Format.
Microsoft Access must be installed on the machine in order to edit the configuration database.

1. On the local machine, start the Microsoft Access program and open the configuration database
found in the configuration folder.
2. In Tables pane of Microsoft Access, double-click the RegSettings table to open the RegSettings table in the right pane of Microsoft Access.
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3. In the ValueName column, find the allow save alarm print key for the IGSS station you
want to edit. The station identification is visible in the Path column and is expressed as StationA, StationB and so on.
4. In the Value column, enter "1" to enable updating the Alarm Print Format for the selected IGSS
station.
5. Click Ctrl+S to save the changes and click File > Exit to close the Microsoft Access program.

You can find a list of the Station identification and the station name in the
registry key HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V13.00.00\CommDrv_HKLM\StationDatabase folder. The Stationno key is the station identification and the value in the Stationno key
is the station name as it is defined in the Configuration tab of the System Configuration form.

Update the Alarm Print Format

1. In the Active Alarms form, click the Customize menu > Alarm Print Format button to open
the Alarm Print Format form.
2. Note the Formats group is inaccessible as you cannot create new Alarm Print Formats.
3. In the Alarm Print Format form,you can:
l

Rearrange the order of the columns

l

Add columns to the displayed columns list

l

Remove columns from the displayed columns list

l

Change the column widths

l

Rename column headers

4. Click the OK button to close the Alarm Print Format form and update the Alarm Print Format.

Restore default Alarm Print Format
You can restore the default Alarm Print format by clicking the Default button in the Alarm Print Format
form.
The Alarm Print Format form is opened by clicking the Active Alarms form > Customize menu > Alarm
Print Format button.
See Also

"Direct alarm message printing" on page 73
"Rearrange the columns" on page 100
"Rename a column" on page 101
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"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103

Printing the alarm list /alarm log
Printing out the Alarm List or Alarm Log as it is displayed in the Active Alarm list or the Alarm Log list.
Set up the print page

1. In the Active Alarms form, click File > Page Setup to open the Page Setup form.
2. Change the page orientation, page margins and the paper size if necessary. Note that some
printers will disable some of these options.
3. Click the OK button to save the page set up and close the Page Setup form.

Print the Alarm list

1. In the Active Alarms form, click File > Print to open the Print dialog.
2. In the Print dialog, you can:
l

change the printer to be used

l

set number of copies to be printed

l

define the font to be applied to the print

l

select to include alarm notes to the print

l

adjust the information to the paper width*

3. Click the OK button to print the alarm list and close the Print form.

*Cut to Paper Width: If this function is selected, the contents of the displayed Alarm List or Log is cut off
if it exceeds the right margin of the printing paper.
If this function is not selected and the contents of the list exceeds the width of one print page, printing is
continued on a second page. In this way you may join two printed pages to see the entire contents of the
list on paper.
See Also

"Direct alarm message printing" on page 73

Alarm: Command line interface
The command line interface is an alternative to the graphical interface to this program. It allows you to
manipulate the program either directly from a command prompt or from the Job Scheduler Module.
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Using this interface, you can automatically print the Alarm List with a fixed interval or activated on an
event in the IGSS system. You can also send the output in an e-mail or export it as a comma-separated file
(.csv)
Printing

There is no -print command as this function is subsumed in each command line parameter. All the listed
Alarm command line parameters will therefore automatically send the alarm list to the printer, except the af<filter name> parameter.

Syntax conventions
The following symbols are used:

Symbol

Bold

Description

Required parameter.

<placeholder> Placeholder for a variable parameter.
|
Separates required parameters. You must use at least one of
(pipe symbol) these parameters in the syntax and you may use two or more of
them.
NOTE: To separate these parameters, put a space between
them.
[parameter] Optional parameter that you may include in the command line.

Syntax

Use the following syntax (separate parameters with a space):
Alm -f<filter name> [-ds<start date>] [-ts<start time>] [-de<end date>] [-te<end time>] [-all]
[-note] [-page]

You must check the Prompt for period box in the Defining Filters for Alarm List dialog when
you create a filter that you will access from the command line. If disabled, Alarm will use the default
period.

All Alarm command line parameters must be entered in lower case.

Parameter

-f<filter name>

Description

Define the alarm list filter to use for the print.
If the name contains spaces, enclose the name in quotation marks
(""). You can also use the root filters: "Active Alarms" and "Alarm
Log".
Do not include a space between the parameter -f and the filter
name.

-af<filter name>

Change the filter used in the Active Alarm list. The Active Alarm
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Parameter

Description

list will start with this filter selected.
This parameter will not send the alarm list to the printer.
-ds<start date>

Start date in the format yyyy/mm/dd or as an offset defined with
the $ parameter (offset in days).

-ts<start time>

Start time in the format hh:mm:ss or as an offset defined with the
$ parameter (offset in seconds).

-de<end date>

End date in the format yyyy/mm/dd or as an offset defined with
the $ parameter (offset in days).

-te<end time>

End time in the format hh:mm:ss or as an offset defined with the
$ parameter (offset in seconds).

-all

All columns are printed (otherwise the columns exceeding one
page are not printed)
This is equivalent to clearing the Cut to paper Width check box
in the Print form.

-note

Includes alarm notes on the printout.
This is equivalent to selecting the Include Notes check box in the
Print form.

-page

Inserts page breaks after alarm notes.
This is equivalent to selecting the New page after note check
box in the Print form.

-landscape

Landscape makes alarm print in landscape mode.

-item

Define the contents to include in the Alarm print:
l

0: Active Alarms

l

1: Alarm log

l

2: Active Events

l

3 Event log

-format<name>

Name of the format to be used. If no format is defined, then the
default format is used.

-csv

Output is to be exported as a comma-separated file (.CSV) and
not printed.
The comma-separated file must either be saved at a location
using the -file<path> parameter and/or sent as an attachment to
an e-mail message using the -mail<address> parameter.

The -csv parameter must be specified
using lowercase letters only.
You can add a title to the e-mail message by using the -title para-
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Parameter

Description

meter.
-file<path>

The full path to the destination file, including the name of the .csv
file.
The default filename is yyyy-mm-dd-hh-mm-ss.csv
The default file path is the GSS folder of the local IGSS installation.

-mail<address>

The output is to be sent as an attachment to the recipient's e-mail
address. If the output is to be sent to more than one e-mail recipient, separate any additional e-mail addresses with a semicolon.
You do not need to use the -file<path> to include the .csv in the email message, but if you do use the -file<path> parameter, then
the specified file will be included in the e-mail message.
If you do not use the -file<path> parameter, the default file name
will be used for the e-mail attachment.
Do not include a space between the parameter -mail and the email address.

-title

The subject line in the e-mail message.

-lfmt<format>

Name the alarm list format to be applied to the alarm report,
where the <format> is the format name to be applied.

-appenddate

Adds the current date and time to the filename.
If you have used the -ds (start date) and/or -ts (start time) parameters , the defined start date and start time will be used instead.

-ymdfolders

Creates year, month and day sub folders to store alarm list
reports when saving alarm list reports as a .CSV file to a specified
destination.
This parameter should be used with the -file<path> parameter.

The parameter elements may not contain parameters of another alarm parameter. For example -affilter-all contains the filter name filter-all where -all at the same time is a valid alarm parameter

Job Scheduler example

This example prints the alarms matching the Analog Alarms filter. The start date is set to the previous
day ($date-1) and end date is set to today $(date). Start time (-ts) and end time (-te) are both set to 7:00
a.m. All columns are printed and alarm notes are included.

Program path:
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"[IGSS InstallPath]\Gss\Alm.exe"
Parameters:

-f"Analog Alarms" -ds$(date-1) -ts07:00:00 -de$(date) -te07:00:00 -all
–note
Working folder:
Command prompt example

This command line prints all alarms matching the Purification filter from the previous day. The printout
shows all columns and includes alarm notes.

Alm -fPurification -ds$-1 -ts00:00:00 -de$ -te00:00:00 -all -note

Alarm Command Line Example

Alm -f"Priority5 and 6" -all -csv -maildk-igss-support@schneider-electric.com

1.11 System Alarm
The System Alarm
In the IGSS software, there is an object called System. This object is used by the IGSS system to generate
alarms under specific conditions.
l

The System object, which is a predefined analog object, can be viewed in the Object Browser in the Definition program. If this object is deleted or renamed, the IGSS system will crash and freeze up until the object is restored.

A system alarm is triggered from the System object under the following four conditions.

1. When the amount of free space on the hard disk of the IGSS single user or server PC is nearly gone
2. When the path to the IGSS application’s report folder is incorrect
3. When there are insufficient Windows user permissions given to the report folder when running in a multi-user environment
4. When the occurrence of an Event in the Event list is also to be displayed in the Active Alarm list

Let’s look at the alarm messages displayed for each situation.

1. Insufficient hard disk space
When the IGSS system registers a low level of hard disk space, then the System alarm is triggered and a
System alarm warning message is displayed:
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Figure 1: Basic System alarm message
You must then shut the IGSS system down and remove enough files from the hard disk to free up at least
20% of hard disk capacity. Then start the IGSS system up again.
The occurrence of this alarm by itself is rare because hard disk capacity nowadays is hardly ever exceeded
by normal SCADA1 systems.
However, the alarm is triggered in connection with the presence of other conditions, which need attention
by the user. These are described in the next two cases.

2. Error in connection with the IGSS application’s report folder: cannot find the report folder

When this situation occurs, the ALL LOGGING STOPPED alarm, as shown in Figure 1 above, will be
triggered as well as a dialog box with an alarm message. When this happens, the ALL LOGGING
STOPPED alarm can be ignored as the true cause of the alarm state.
This alarm arises typically when configuring a multi-user system and looks like this:

Figure 2: Cannot find the report folder warning

1 Supervisory Control & Data Acquisition
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This message indicates that the path to the IGSS application’s report folder has somehow been incorrectly
keyed in. Therefore, check first in the System Configuration module on the server PC on the Configuration tab under Report folder. Check the following two things:

1. Make sure that you’ve correctly keyed in the UNC path to the report folder, i.e. \\<IP address>or <PC name>\<report
folder name>\

l

Remember to include the last forward slash after the name of the report folder.

2. Make sure that you’ve spelled everything correctly

This should remedy the problem.

3. Error in connection with the IGSS application’s report folder: access denied

When this situation occurs, the ALL LOGGING STOPPED alarm, as shown above, will be triggered as well
as a dialog box with an alarm message. When this happens, the ALL LOGGING STOPPED alarm can be
ignored as the true cause of the alarm state.
This alarm arises typically when configuring a multi-user system and looks like this:

Figure 3: Access denied warning
This message indicates that sharing and/or setting of permissions on the report folder has not been correctly carried out. Do the following:

1. Use Windows Explore to find the folder where the IGSS application resides.
2. Right click on the folder name and choose Sharing and Security…
3. Share the folder and then click on the Permissions button to set user permissions to Full Control.
4. Click OK to save and exit.

This should remedy the problem.

4. Display an Event in the Active Alarms list
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This last example of the triggering of a System alarm is not related to an error situation. Here the System
object is used to display the occurrence of an Event in the Active Alarms list. For a detailed explanation
click this link Event.
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Chapter 2: The Event List
2.1 What is the Event List ?
Use the Event List to get a quick overview of the most important system and object events. The events in
the list are user-defined and can be configured from the Definition or the Supervise modules.
The Event List is displayed in the bottom half of the Active Alarms form. It contains two root nodes, Active Events and Event Log. For both of these root nodes, filters can be defined exactly as in the Alarm List.
You can hide the Event list in the Active Alarms form by clearing the Show Event list check box on the
Alarms tab in the System Configuration form.
The columns of the Event list can be rearranged and the events can be sorted just like the Alarm List
columns.

See Also
Event Types
"Active Events and the Event Log" on page 85
"The fields in the Event List" on page 86
"Showing events in the Alarm List" on page 87
"Printing event alarms" on page 88

2.2 Active Events and the Event Log
The Event List has two root nodes in the tree view.
l

l

The Active Events node displays all events from the last hour or the 500 latest events.
The Event Log node displays all historical and active events. The maximum number of events displayed in the list is determined by the Max. alarm log entries field on the Alarm tab of the System Configuration form.
Note that the max. number of entries include both alarms and events.

For both nodes filters can be defined. The filters will appear below the root node. The root node can be
expanded to show the filters or collapsed to hide the filters.
In this example, we have defined a filter extracting user login/logout information. We know that the event
type has been named “User login/logout” so this is our filter criterion.
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See Also
"Define a new filter" on page 91

2.3 The fields in the Event List
The table below shows an explanation of the fields specific to the Event List. The name of the event is
defined either in the Definition or the Supervise Modules.
For an overview of the event types, click the header in the table.

Event type

Event

Info 1

Info 2

Info 3

OP Connect/Disconnect

User- “Connect”, “Disdefined connect”, “Lost conname nection”, “LAN B”

IGSS station
name

-

Periodical

User- defined
name

-

-

System start/stop

User- “Data collection stardefined ted” or
name ”Data collection
stopped”

-

-

User defined

User- defined
name

Object name

Area name

User login/logout

User- “Login” or
defined ”Logout”
name

User name

IGSS station name

Writing
stopped/started

User- “Start write” or
defined ”Stop write”
name

-

-

Error packet

User- Driver number, node
defined number
name

Error group
Error code, subcode
(decimal or hexa- (decimal or hexadecimal)
decimal)
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2.4 Showing events in the Alarm List
Enabling alarms on events

When new events are defined, it is possible to enable the Alarm on event check box.
This means that the event will appear both in the Event List and in the Alarm List.
The operator will thus see the number of alarms change in the Alarm Icon and see the alarm in the list.

Viewing events in the Alarm List

The alarm will be shown as alarm number 90. The alarm text will be the event name. The alarm properties
including alarm and acknowledgment colors are taken from alarm number 90. If required, the alarm properties can be changed in the Definition module.
This example shows a number of events at the top of the Alarm List.
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Acknowledging event alarms

From the Alarm List the operator can acknowledge the alarm. Once acknowledged, the alarm is also
ended and is archived in the Alarm Log.

2.5 Printing event alarms
Prepare the Event List for printing

1. In the Customize menu, select Alarm Print Format.
2. Do the following:

l

l

l

In the Columns Displayed list, remove all unwanted columns.
In the All Columns list, select the columns specific to the Event List one-by-one and click the Add button.
These fields will be printed when a new event occurs. For all other alarms, the fields will be empty.
In the Columns Displayed list, use the Move Up and Move Down buttons to adjust the order.

Show picture

3. Click the OK button.

Print the Event List

1. In the File menu, select Print.
2. If required, change the print settings.
3. Click Print.

l

The list will now be printed according to the setup in the Alarm Print Format dialog box.

Print events on the alarm printer
In order to have all events printed on the alarm printer as soon as they occur, set up the following:
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1. In the System Configuration program, click the Reports tab.
2. In the Alarm printer section, select Direct (one line at a time on a matrix printer) or Windows (the page is printed
when the page is filled).
3. Click the Printer button and select the relevant printer.
4. Close the program and save changes.
5. Open the Definition program
6. In the Edit menu, select Alarm Texts.
7. Select alarm text number 98 named Event and click Edit.
8. In the Edit Alarm Description dialog box, select the To Print check box.

Show picture

9. Click OK and then Close.
10. In the File menu, select Install Configuration.

l

If you select Online Update in this case, the change will not be applied. The Data Collection must be restarted for the
change to take effect.

4. From the IGSS Master > Home Tab, click the Restart button to re- start the configuration .

l

New events will now be printed on the alarm printer. The alarm number will be 98 and the alarm text will be “Event”.

2.6 Updating and Freezing the Event List
Update the list
Background information
The process values shown in the Alarm List and Event List are not continuously refreshed. They are
updated whenever the Worst Value of the object value has changed, or at specific intervals set by the
System Integrator during system design. IGSS therefore provides an Update facility so you can read and
load the newest process values whenever needed.

Procedure

1. In the Tree View, select the list you wish to update.
2. Move into the selected list in the right-hand section of the screen.
3. In the Tool Menu, click Actions > Update.
4. The entire list is updated.

l

For the options of the Actions menu to become available, you must have moved the cursor out of the Tree View into the
alarm list or alarm log !

Shortcut
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1. You are inside the list.
2. Simply click the right mouse button.
3. This opens the Actions function box so that you can now conveniently activate the Update function.

See also

Freeze the list

Background information
In situations where you have a cluster of alarms in rapid succession it might be useful to freeze the list for
a short period at its current status. The freeze period is predefined by the development engineer during
system design and cannot be changed by the operator.
Default setting: 30 seconds

Procedure

1. In the Tree View, select the list you wish to freeze.
2. Move into the selected list in the right-hand section of the screen.
3. In the Actions menu, select Freeze.

l

For the options of the Actions menu to become available, you must have moved the cursor out of the Tree View into the
Alarm List or the Event List.

Shortcut

1. You are inside the list and a message line is selected.
2. Click the right mouse button.
3. This opens the Actions function box so that you can now conveniently activate the Freeze function.

l

A seconds counter in the screen title bar indicates the ‘frozen’ status and the number of seconds still to go.

See also
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2.7 Customizing, Sorting and Filtering
Filter the Event list
Define a new filter
You can create a filter to reduce the records displayed in the list panes of the Active Alarms form to only
those records that meet the filter criteria.

To create a new filter

1. In the left pane of the Active Alarms form, select the record type to be displayed: Active
Alarms, Alarm log, Active Events or Event log. The new filter will only be applied to the selected
display type.
2. Click Customize > New Filter to open the Defining Filters form. You can also click the New
Filter button in the toolbar to open the Defining Filters form.
3. In the Filter name field on the Defining Filters form, enter a filter name.
The filter name is not required to be unique and it is possible to create identical filter names. It
is recommended to create unique filter names to better distinguish filters from each other.

4. In the Edit Condition group:
1. In the Property field, select the filter property from the drop down list.
2. In the Condition field, select the filter condition of the property from the drop down
list. The displayed properties depend on the selected property.
3. In the Value field, select the filter value from the drop down list. The filter value will
be applied to the condition.
5. Click the Add button to submit the filter condition to the filter.
6. If you need to create successive filter conditions, select a logical operator to apply to the next filter condition (And / Or) and repeat steps 4 and 5 above.
7. Click the OK button to save the filter and close the Defining Filters form.

A filter can only contain a maximum of 10 filter criteria.
See Also

"Filter the Active Alarms form " on page 45
"Multiple alarm filter conditions" on page 47
"Edit an existing filter" on page 92
"Delete an existing filter" on page 93
"Define special filter parameters" on page 93
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Edit an existing filter
You can edit existing filters, adding new filter conditions, deleting or adjusting existing conditions.
Some filters have been write-protected to disable editing. If this is the case, you must have sufficient
user rights to edit a write-protected filter. User rights are determined by the User Group you are member of in the IGSS User Administration module.

To edit an existing filter

1. In the left pane of the Active Alarms form, select the record type to be displayed: Active
Alarms, Alarm log, Active Events or Event log.
2. Click Customize > Edit Filter to open the Defining Filters form. You can also click the Edit
Filter button in the toolbar to open the Defining Filters form.
3. To rename the filter, enter a new filter name in the Filter name field on the Defining Filters
form.
The filter name is not required to be unique and it is possible to create identical filter names. It
is recommended to create unique filter names to better distinguish filters from each other.

4. To edit an existing condition, select the filter condition you want to edit in the Filter Conditions group.
1.

In the Edit Condition group:

2. In the Property field, select a new filter property from the drop down list.
3. In the Condition field, select a new filter condition of the property from the drop
down list. The displayed properties depend on the selected property.
4. In the Value field, select a new filter value from the drop down list. The filter value
will be applied to the condition.
5. To delete an existing condition, select the filter condition you want to edit in the Filter Conditions group and click the Delete button.
6. To add a new Filter condition,
1. In the Property field, select the filter property from the drop down list.
2. In the Condition field, select the filter condition of the property from the drop down
list. The displayed properties depend on the selected property.
3. In the Value field, select the filter value from the drop down list. The filter value will
be applied to the condition.
4. Select the relevant logical operator to apply to the new filter condition.
5. Click the Add button to submit the filter condition to the filter.
7. Click the OK button to save the filter and close the Defining Filters form.

See Also

"Filter the Active Alarms form " on page 45
"Define a new filter" on page 91
"Delete an existing filter" on page 93
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"Define special filter parameters" on page 93
Delete an existing filter
You can delete an existing filters from the local machine, removing it from the Active Alarms forms.
Deleting a filter does not require user confirmation and will be removed immediately. A deleted filters can
not be restored and you must recreate the filter if you regret deleting the filter.

Filters are saved locally on the machine and are available to all operators who use the IGSS configuration on the local machine. If you delete a filter, you will remove access to the filter for all operators that use the machine.

To delete a filter

1. In the left pane of the Active Alarms form, select the record type to be displayed: Active
Alarms, Alarm log, Active Events or Event log. The new filter will only be applied to the selected
display type.
2. Click Customize > Delete Filter to delete the filter. You can also click the Delete Filter button in the toolbar to delete the filter.
There is no user confirmation dialog to confirm the removal of the filter.

See Also

"Define a new filter" on page 91
"Edit an existing filter" on page 92
"Define special filter parameters" on page 93
Define special filter parameters
You can apply the following parameters to an existing filter to change the characteristics of the filter, specializing the filter in some cases and expanding the filter functionality in others.
All parameters can be combined with each other.

Create a Global filter
All filters are by default local filters and are saved on the local machine. A filter defined by one operator station will not be accessible to other users on other operator stations.
You can make a filter global across the IGSS configuration by selecting the Global check box in the Defining Filters form when creating or editing a filter.
A global filter is saved in the IGSS configuration and distributed to all online stations when they connect to
the IGSS server. Global filters are also synchronized between IGSS servers in a dualized (hot standby)
IGSS server environment.
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Global alarm filters can be assigned to the selected alarm printer for the station in the System Configuration form > Reports tab > Alarm group to only print alarms that satisfy the global filter conditions.

Create a Write-protected filter
By default, any operator can edit or delete a filter, as well as create a new filter. You can prevent operator
from editing a filter by protecting the individual filter. When you protect a filter, only operators that are
IGSS users and have access to the Can use System Commands global rights may edit a protected filter.
Write-protecting a filter therefore requires the IGSS User Administration module is enabled, set up and in
use on the IGSS configuration.
You can write protect a filter by selecting the Protect check box in the Defining Filters form when creating or editing a filter.
You can combine the Write Protected filter with the User limited filter for additional filter protection.

Create a filter which prompts for a filter period
By default, the filter is applied to all records in the active alarm list, active event list, alarm log or event
log regardless of start or end date and time.
You can create a filter which requires the user to enter the start date and time and the end date and time of
the alarm or event before applying the filter to the event or log list.
Select the Prompt for Period check box in the Defining Filters form when creating or editing a filter to
create a period-defined filter that can apply user input for start and end dates.

Create a user limited (Exclusive) filter
A user limited (Exclusive) filter is a filter which only certain IGSS users may apply to the log list or event
list. Any operator can apply any log or list filter by default, but you can prevent a filter from being applied
by users who do not have sufficient rights by using the Exclusive parameter on the filters.
The IGSS User Administration module must be enabled, set up and in use on the IGSS configuration
and the Exclusive parameter must be applied to at least one filter to enable user limited filters.
If the IGSS User Administration module is enabled and the Exclusive parameter applied to at least
one filter, then only the users with the Can Administer Global Right may apply any filter. Users without
the Can Administer global right can only apply filters that have the Exclusive check box selected.
The Exclusive parameter is applied to a filter by selecting the Exclusive check box in the Defining Filters form when creating or editing a filter.
You can combine the User limited filter with the Write Protected filter for additional filter protection.

Create an Alarm Report filter
The Alarm Report contains additional alarm statistics when printed which the active alarm list does not display.
You can set up the active alarm list to display the additional alarm statistics from the Alarm Report by
selecting the Format as 'alarm print' check box in the Defining Filters form.
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The following columns are displayed in the Active Alarm list:
l

The object value when the alarm was started

l

The object value when the alarm was acknowledged

l

The object value when the alarm was ended

Remove an IGSS Mobile filter
By default, all filters are enabled by be used by IGSS Mobile users. You can remove access to the filter
from IGSS Mobile Users by clearing the Include in IGSS Mobile check box in the Defining Filters form.
See Also

"Define a new filter" on page 91
"Edit an existing filter" on page 92
"Direct alarm message printing" on page 73
Set a default Active Alarms or Active Events list filter
You can set a specific list filter as the default list filter. The default filter will be applied to the active alarm
list or Active Events when you open the Alarm Module.
In a multi-user environment, this setting only applies to the machine on which it is set. The default list filter can therefore not be uploaded to the IGSS server and distributed to the other operator stations.

To set a default active alarm list filter

1. In the upper left pane of the Active Alarms form, navigate to the filter you want to make the
default filter in the Active Alarms node.
2. Click Customize > Set as Default Filter to make the selected filter the default filter for the
Active Alarm list. You can also click the Set as Default Filter button in the toolbar.

To set a default Event list filter

1. In the lower left pane of the Active Alarms form, navigate to the filter you want to make the
default filter in the Active Events node.
2. Click Customize > Set as Default Filter to make the selected filter the default filter for the
Active Events list. You can also click the Set as Default Filter button in the toolbar.

See Also

"Define a new filter" on page 91
"Set a default Alarm log or Event log filter" on page 96
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Set a default Alarm log or Event log filter
If the alarm or event log contains records that exceed the user-defined maximum alarm or event log limit,
the latest alarm or event logs will be displayed. To find older alarm or event logs, you must create and
apply an alarm or event log filter to display the desired alarm or event log entries.
You can create a default log filter which will automatically filter the log list when you click the respective
folder (Alarm log or Event log) in the lower left pane of the Active Alarms form.
Creating a default log list filter is different than creating an Active Alarm list filter or Active Event list filter.
To create a default log list filter, you must create an log list filter and prefix the filter name with an asterisk
(*)
For example, if you create an alarm log filter called "Pump alarms ", you can set the filter as the default
Alarm log list filter by changing the name of the filter to "*pump alarms".

Multiple default log filters
You can only apply one default Alarm log list filter and one Event log list filter although you can define
many log list filters with a prefixed asterisk in the filter name.
The default log list filter is sorted alphabetically and the first appearing filter with a prefixed asterisk will be
applied as the default log list filter.
For example, there are two log list filters defined: *Afilter and *Bfilter. The log list filter named *Afilter will
be applied as the default log list filter as it comes before *Bfilter when sorted alphabetically.
See Also

"Define a new filter" on page 91
"Set a default Active Alarms or Active Events list filter" on page 95

The Event List Format
Create a new Alarm List Format
You can change the physical appearance of the Alarm or Event list, adding columns to the list and removing
columns from the list. As each column displays alarm or event information, you can define how much information the alarm or event list is to display to the operators.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.
You can create a new Alarm List Format to save the column layout of the alarm list or event list in the alarm
list format and applying the Alarm List Format to the alarm list or event list.
Once an new Alarm List Format has been created, other operators can also apply the format to the alarm
list or event list by selecting the format.
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Alarm List Formats are available to all IGSS users and can be applied by any IGSS user of the configuration.
The Alarm List Format is specific to the IGSS configuration on the local machine and cannot be distributed
to other machines or IGSS configurations.

To create a new Alarm List Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Alarm List Format form, click the New button to open the New Format dialog and
enter a format name. The format name is not required to be unique and it is possible to create
identical format names. It is recommended to create unique names to better distinguish formats
from each other.
4. In the Formats group (lower part of the Alarm List Format form), make sure the new alarm
list format is selected.
5. In the upper part of the Alarm List Format form, you can:
l

Rearrange the order of the columns

l

Add new columns to the columns displayed

l

Remove existing columns from the columns displayed

l

Change the column header name

l

Change the column width

6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Apply an Alarm List Format to the Active Alarms form" on page 98
"Delete an Alarm List Format" on page 99
"Rearrange the columns" on page 100
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
"Rename a column" on page 101
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Apply an Alarm List Format to the Active Alarms form
You can apply an existing Alarm List Format to the Active Alarms form, changing the layout and appearance of the columns in the Alarm list, event list, alarm log list and the event log list. only one Alarm List
Format can be applied to the Active Alarms form at a time.
Alarm List Formats are applied to all users and cannot differentiate between IGSS users.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To apply a new Alarm list Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to apply. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Delete an Alarm List Format" on page 99
Edit an Alarm List Format
You can edit an existing Alarm List Format, changing the column layout, order and header names.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To edit an Alarm List Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
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4. In the upper part of the Alarm List Format form, you can:
l

Rearrange the order of the columns

l

Add new columns to the columns displayed

l

Remove existing columns from the columns displayed

l

Change the column header name

l

Change the column width

5. Click the Save button to save the column layout to the new Alarm List Format.
6. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Apply an Alarm List Format to the Active Alarms form" on page 98
"Delete an Alarm List Format" on page 99
"Rearrange the columns" on page 100
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
"Rename a column" on page 101
Delete an Alarm List Format
You can delete an Alarm List Format, removing it from the list of formats.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.
Once a format has been deleted, it cannot be restored. You must recreate it
again if you want to apply the format to the Active Alarms form.

To delete an Alarm List Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
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3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to delete. The upper part of the Alarm List Format form, will change, reflecting the column layout options for the selected Alarm List Format.
4. Click the Delete button to delete the selected alarm list format
5. Click the OK button to close the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Apply an Alarm List Format to the Active Alarms form" on page 98

Change the list format
Rearrange the columns
The columns in the Active Alarms list are displayed in the order listed in the Alarm List Format form. You
can change the order of the displayed columns in the Active Alarms form by editing the column properties in the Alarm List Format applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To rearrange the columns in the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select a column and use the Move Up and Move Down buttons to rearrange the order of
the column will be displayed in the Active Alarms form.
5. Click the Save button to save the column layout to the new Alarm List Format.
6. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
"Rename a column" on page 101
"Remove columns" on page 101
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"Add columns" on page 102
"Change the column width" on page 103
Rename a column
You can rename a column header, changing the title of the column as it is displayed in the Active Alarms
form by editing the Alarm List Format applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To rename a column header in the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to change the header of
5. In the Change Column Name field enter the new column header to be displayed in the Active
Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Remove columns" on page 101
"Add columns" on page 102
"Change the column width" on page 103
Remove columns
The columns in the Active Alarms list are displayed in the order listed in the Alarm List Format form. You
can remove columns from the Active Alarms form by editing the column properties in the Alarm List
Format applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.
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To remove a column from the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to remove.
5. Click the Remove button to remove the selected column from the Active Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Rename a column" on page 101
"Add columns" on page 102
"Change the column width" on page 103

Directly in the list

1. Click on the right-hand limiting line of the column you wish to remove, using the left mouse button and keep the
mouse button pressed.
2. The cursor changes its shape to a cross and highlights the vertical column delimiter.
3. Keep the left mouse button depressed and drag the cursor to the left until the right line covers the left line. In
this way, the width of the column has been reduced to nothing and the column is removed from the list.

Only a column which was removed (collapsed) directly in the list by dragging its right-hand limiting line to the left until clearance,
can be retrieved again directly in the list, without using menu functions.
The first method of removing columns is the more permanent layout change. It can only be undone by using the ADD button in the
Configure Columns dialogue.

Add columns
The columns in the Active Alarms list are displayed in the order listed in the Alarm List Format form. You
can add columns from the Active Alarms form by editing the column properties in the Alarm List Format
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applied to the Active Alarms form.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.

To remove a column from the Alarm list

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to add.
5. Click the Add button to add the selected column to the Active Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Rename a column" on page 101
"Remove columns" on page 101
"Change the column width" on page 103

Directly in the list
Place the crosshair cursor onto the limiting line of the collapsed column and drag it to the right until the
retrieved column has reached the width required.

Change the column width
You can change the column width as it is displayed in the Active Alarms form by editing the Alarm List
Format applied to the Active Alarms form or directly in the Active Alarms list.

The alarm list format can be applied to the Event list, Event log and Alarm log as well.
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To change a column width by editing the format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to edit. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. In the list box in the Columns Displayed group in the upper part of the Alarm List Format
form, select the column you want to change the width of
5. In the Width field enter the new column width of the column (expressed in pixels) displayed in
the Active Alarms form.
6. Click the Save button to save the column layout to the new Alarm List Format.
7. Click the OK button to apply the new alarm list format to the Active Alarms form.

To change a column width directly in the Active Alarms list

1. Left-click on the right-hand edge of the column whose size you wish to reduce or widen and keep
the mouse button pressed.
2. The cursor changes its shape to a cross and highlights the vertical column delimiting line.
3. Maintaining the left mouse button depressed, drag the line to the left or to the right.
4. Release the mouse button as soon as you have obtained the required column width.

See Also

"Create a new Alarm List Format" on page 96
Rearrange the columns
"Rename a column" on page 101
"Remove columns" on page 101
"Add columns" on page 102

The default Event List format
The default List or Sort Format
IGSS contains a system default for the Alarm List format and the Sort Order formats. The system default
formats are saved on the local machine of the operator station and can be restored to the Active Alarms
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form by the operator if necessary. You can see the contents of the system default list format in the
See Also section below.

Changing the System Default List Format
You can also update the system default formats from the Active Alarms form if you want to use another
default format than the original system default. The alarm list format presently in use is saved as the system default, automatically updating the system default. Once the system default has been updated or
changed, you cannot restore the original system default format again.

The option to save a format as the system default is normally not accessible to users and must be
enabled by a System Designer with administrator rights on the local machine.

See Also

" The system default List format" on page 105

The system default List format
The Alarm List or Alarm Log contains by default the following information in the order shown:

l

S.No. = Sequence Number

l

Start Date

l

Start Time

l

Acknowledge Time

l

End Time

l

Object Name

l

Worst Value

l

Alarm Text

l

Area Name

l

Object Description

l

Value

l

Priority

l

Alarm Number

l

Acknowledge Date

l

End Date

l

Alarm State

l

Driver Id.

l

Node Id.

l

User name

l

The Icons
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Restore the Alarm list default format
You can restore the alarm list format to the system default, restoring all the columns selected for display,
column rankings, column header names and column widths with the column layout from the system default
format.

To restore the system default alarm list format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to restore the system default layout for. The upper part of the Alarm List
Format form, will change, reflecting the column layout options for the selected Alarm List
Format.
4. Click the Default button to insert the system default column layout into the selected alarm list
format. The upper part of the Alarm List Format form, will change, displaying the system
default column layout for the selected Alarm List Format.
5. Click the OK button to apply the alarm list format and close the Active Alarms form.

You can update the system default list format, creating your own column layout as the system default.
See Also

" The system default List format" on page 105
"Update the System default alarm list format" on page 106
Update the System default alarm list format
The column layout in the system default Alarm List Format can changed, creating your own column layout
as the system default. The new column layout will be applied to the selected Alarm List Format every time
the Default button in the Alarm List Format form is clicked to restore the default column layout.
The System Default Alarm List Format is specific to the configuration on the local machine and cannot be
distributed to other machines or configurations.

Once you have changed the system default Alarm List Format, you cannot
restore it. The changes become the new system default.
By default, the menu option to update the system default Alarm List Format is disabled and must be
enabled in order to update the system default.

Enable update of system default Alarm List Format update using the registry editor (This station only)
To enable updating system default Alarm List Format for all configuration operators on the local machine.
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1. Open the Registry Editor form on the local machine. Click Start and type "Regedit.exe" in the
search field of the Windows Start menu.
2. In the Settings folder in HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V13.00.00\Alarm32_HKLM, right-click on the allow save default key and select
Modify.
3. In the Value Data field of the Edit DWORD (32-bit) Value form, enter "1" and click OK to
save.
4. Click File > Exit to exit the Registry Editor form and save the registry values.

Enable update of system default Alarm List Format update using the Configuration database
(other stations)
You can use the Configuration database to enable this operator station or other IGSS stations update the
system default Alarm List Format.
Microsoft Access must be installed on the machine in order to edit the configuration database.

1. On the local machine, start the Microsoft Access program and open the configuration database
found in the configuration folder.
2. In Tables pane of Microsoft Access, double-click the RegSettings table to open the RegSettings table in the right pane of Microsoft Access.
3. In the ValueName column, find the allow save default key for the IGSS station you want to
edit. The station identification is visible in the Path column and is expressed as StationA, StationB and so on.
4. In the Value column, enter "1" to enable updating the system default Alarm List Format for the
selected IGSS station.
5. Click Ctrl+S to save the changes and click File > Exit to close the Microsoft Access program.

You can find a list of the Station identification and the station name in the
registry key HKEY_CURRENT_USER\Software\Schneider Electric\IGSS32\V13.00.00\CommDrv_HKLM\StationDatabase folder. The Stationno key is the station identification and the value in the Stationno key
is the station name as it is defined in the Configuration tab of the System Configuration form.

See Also

"Save the list format as the default format" on page 108
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Save the list format as the default format
When updating the system default Alarm List format, the Alarm List Format presently applied to the Active
Alarms form is used. You can save the Alarm List Format as the system default Alarm List Format, effectively updating the system default.
By default, the menu option to update the system default Alarm List Format is disabled and must be
enabled in order to update the system default.
To update the system default Alarm List Format you must:

1. Apply a the Alarm list Format you want to turn into the system default
If the alarm list format you want to use already is applied to the Active Alarms form, you can skip this
step.

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Alarm List Format to open the Alarm List Format form. You can also
click the Format List button in the toolbar to open the Alarm List Format form.
3. In the Formats group (lower part of the Alarm List Format form), select the Alarm List
Format you want to use. The upper part of the Alarm List Format form, will change, reflecting
the column layout options for the selected Alarm List Format.
4. Click the OK button to apply the alarm list format to the Active Alarms form.

2. Save the Alarm List Format as the system default
In the Active Alarms form, click Customize > Save as Format Default.
See Also

"Update the System default alarm list format" on page 106

Sort the Event List
Change the sorting order in the list
The alarms or events in the alarm or event list are displayed using the default sort order. You can change
the sort order of the displayed alarms or events, displaying the order which is relevant for your particular
alarm processing, for example sorting the alarms in the list by alarm priority first and then the Alarm start
date.

The sort format can be applied to the Event list, Event log and Alarm log as well.
You can change the sort order in the Alarm list in two ways:
l

Applying a Sort Format to the list

l

Directly on the list
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Applying a Sort format to the list
You can apply an existing sort format to the Alarm or event list. A Sort format is a collection of saved sort
order set up, including sorting direction which can be applied to the alarm or event list. Sort formats can be
created, edited and deleted freely by operators but cannot be distributed to other IGSS stations or other
machines.
You can also restore the default sort order from the system by using Sort formats.

Directly in the list
You can change the sorting order directly in the Alarm/Event list or log by clicking on the column title you
wish to use as sorting criterion. The sorting direction will toggle between ascending and descending when
you click the column header, sorting the records in the Alarm/Event list or log.
See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Create a new Sort format
You can create a new Sort format to save the sort order of the alarm or event list in the Sort format and
applying the Sort format to the alarm or event list.
Once an new Sort format has been created, other operators can also apply the format to the alarm or event
list by selecting the format.
Sort Formats are available to all IGSS users and can be applied by any IGSS user of the configuration.
The Sort Format is specific to the IGSS configuration on the local machine and cannot be distributed to
other machines or IGSS configurations.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To create a new Sort Format

1. Click in the alarm or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Set Sort order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
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3. In the Set Sort Order form, click the New button to open the New Format dialog and enter a
format name. The format name is not required to be unique and it is possible to create identical
format names. It is recommended to create unique names to better distinguish formats from
each other.
4. In the Formats group (lower part of the Sort Order form), make sure the new alarm list format
is selected.
5. In the upper part of the Set Sort Order form, Sort group
1. Select the column you want to change the sort order for and click the Move Upor
Move Down buttons to change the sort order, moving the selected column up or
down the column list.
2. Select the Ascending / Descending options to change the sort direction of the selected column.
6. Select a new column and repeat step 5 until you are satisfied with the new sort order.
7. Click the Save button to save the column layout to the new Sort Format.
8. Click the OK button to apply the new Sort Format to the Active Alarms form.

See Also

"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Apply a Sort Format
You can apply an existing Sort Format to the Active Alarms form, changing the sort order of the records in
the Alarm or event list. Only one sort order can be applied to the Active Alarms form at a time.
The sort order is applied to all users and cannot differentiate between IGSS users.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To apply a new Sort Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to apply. The upper part of the Set Sort Order form, will change, reflecting the sorting order for
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the selected Sort Format.

4. Click the OK button to apply the new sort order to the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Delete a Sort Format" on page 112
"Restore the default Sort Format" on page 112
Edit a Sort Format
You can edit an existing Sort Format, changing the column layout, order and header names.

The sort format can be applied to the Event list, Event log and Alarm log as well.

To edit a Sort Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize > Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to edit. The upper part of the Set Sort Order form, will change, reflecting the sorting order for
the selected Sort Format.
4. In the upper part of the Set Sort Order form, Sort group, select the column you want to
change the sort order for and click the Move Up or Move Down buttons to change the sort
order, moving the selected column up or down the column list.
5. Select the Ascending / Descending options to change the sort direction of the selected
column.
6. Select a new column and repeat step 5 until you are satisfied with the new sort order.
7. Click the Save button to save the column layout to the selected Sort Format.
8. Click the OK button to apply the new sort format to the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
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"Restore the default Sort Format" on page 112
Delete a Sort Format
You can delete an Sort Format, removing it from the list of formats.

The sort format can be applied to the Event list, Event log and Alarm log as well.
Once a format has been deleted, it cannot be restored. You must recreate it
again if you want to apply the format to the Active Alarms form.

To delete an Sort Format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to delete. The upper part of the Set Sort Order form, will change, reflecting the sorting order
for the selected Sort Format..
4. Click the Delete button to delete the selected Sort Format
5. Click the OK button to close the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Restore the default Sort Format" on page 112
Restore the default Sort Format
When IGSS is installed, the program already contains a system default sort order already applied to Active
Alarms list. When you create and apply sort formats to the Active Alarms list, the sort order will change to
the new sort order.
You can restore the default sort order to the Active Alarms list by updating a sort format with the default
sort order and then applying the sort format to the Active Alarms list.

The sort format can be applied to the Event list, Event log and Alarm log as well.
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To restore the default sort format

1. Click in the alarm list or event list pane (right pane) of the Active Alarms form to bring the list
view in focus.
2. Click Customize> Set Sort Order to open the Set Sort Order form. You can also click the
Sort Order button in the toolbar to open the Set Sort Order form.
3. In the Formats group (lower part of the Set Sort Order form), select the Sort Format you want
to restore the default sort order for. The upper part of the SeetSort Order form, will change,
reflecting the sort order and sorting directions of the columns.
4. Click the Default button to insert the default sort order and sort direction into the selected sort
format. The upper part of the Set Sort Order form, will change, displaying the new sort order.
Format.
5. Click the OK button to apply the sort format and close the Active Alarms form.

See Also

"Create a new Sort format" on page 109
"Edit a Sort Format" on page 111
"Apply a Sort Format" on page 110
"Delete a Sort Format" on page 112
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Chapter 3: The Super Alarm Program
3.1 What is Super Alarm ?
Definition
Super Alarm allows you to receive alarms from plants at remote locations via the Internet. These alarms
can be viewed on so-called client PCs at one or more locations geographically removed from the plant.

Use
The following describes some typical situations where Super Alarm might be employed.
l

l

l

Main plant responsible for alarm surveillance of one or more secondary plants
Production operations HQ in a large production complex located away from actual production lines
responsible for total production surveillance.
Evening, night shift or weekend duty personnel carrying out surveillance responsibilities from their
private residences.

3.2 How it works
The Super Alarm workflow
The following flowchart gives you an overview of the workflow involved in setting up and using Super
Alarm.
For details about a step, click its box.

Graphical overview
The following figure shows a simple Super Alarm setup.
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3.3 Before you begin
Before you start setting up the alarm server(s) and client(s), the following preconditions must be met:
l

l

l

The AMS/WinPager option must have been purchased and installed on the alarm server(s).
Each alarm that you want to view through Super Alarm must have the To WinPager option
enabled
(this is done as part of the alarm text definition)
The alarm server(s) and client(s) must be connected to the Internet via TCP/IP

When these preconditions are fulfilled, click See Also to continue with the alarm server and client setup
procedures.

See Also

3.4 Set up the alarm server
On the alarm server, you specify each user you want to authorize to view alarms via Super Alarm.

1. Open the System Configurationprogram.
2. Select the server station and click the Access Control tab.
3. Click Add User.
4. Type the appropriate user name and password and click OK.

l

The users permitted to use Super Alarm are completely separate entities from the users defined in
User Administration. An authorised Super Alarm user need not necessarily be an authorised user in
User Administration and vice versa.

5. Repeat steps 2 and 3 for all Super Alarm users.
6. In the TCP/IP port field, type the logical port number you want to use.
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l

It is recommended to use the default port number. Do not use port numbers lower than 4000, as they are often used for
other purposes.

The Super Alarm server is now set up and the client can connect to the server using an authorized user
name and password.

To edit or remove a Super Alarm user, select the user name and click Edit
User or Remove User, respectively.

3.5 Set up the alarm client
If you have a full IGSS installation, skip step 1.

1. It is recommended that you install the Demo version of IGSS onto your computer to run the
Super Alarmprogram.
2. To start the Super Alarm program, make a shortcut to the Alarm program and add the command
line parameter –s. Double-click the shortcut.

Show picture

1. Select Internet → Configure Servers.
2. Click Add.
3. Do one of the following:

l

l

In the Server Name box, type the computer name or host name of the alarm server
(do not use the IGSS server name).
In the IP Address box, type the IP address of the alarm server.

2. In the TCP/IP Port number box, type the logical TCP/IP port number as specified in System
configuration form on the alarm server.
The default port number is automatically suggested.
3. In the User name box, type the name of an authorized user.
4. In the Password box, type the password.
5. In the Description of server box, you can type an optional description of the server.

1. Click OK.
2. Repeat steps 4 to 10 for each alarm server you want to connect to.
3. Click Close.
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l

The alarms from the configured servers will now appear in the list. The Server ID column shows
you which server sent the alarm. For an example, click See Also.

If you get three asterisks (***) in the Server ID column, the alarm client is not connected to the alarm
server. In that case, check that the TCP/IP connection between the server and the client is properly
configured.

3.6 Example: Viewing alarms from remote plants
In this example, the alarm client is connected to three different IGSS servers: The Main, East, and South
plants.
Note that the Server ID column identifies the server which delivered the alarm. In this case, we have configured the servers with the full host name including the Web server name, for example, South.sevent.dk.
Alternatively, you can use the computer name or the IP address of the alarm server. But the latter is, of
course, harder to recognize for the user.
To show you what happens if the alarm client is not properly connected to the alarm server, a fourth IGSS
server has been configured, North.sevent.dk. As you can see, three asterisks (***) appear in the
Server ID column and the Alarm text “Not connected to server” is shown.
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Chapter 4: Command Line Interface
4.1 Alarm: Command line interface
The command line interface is an alternative to the graphical interface to this program. It allows you to
manipulate the program either directly from a command prompt or from the Job Scheduler Module.
Using this interface, you can automatically print the Alarm List with a fixed interval or activated on an
event in the IGSS system. You can also send the output in an e-mail or export it as a comma-separated file
(.csv)
Printing

There is no -print command as this function is subsumed in each command line parameter. All the listed
Alarm command line parameters will therefore automatically send the alarm list to the printer, except the af<filter name> parameter.

Syntax conventions
The following symbols are used:

Symbol

Bold

Description

Required parameter.

<placeholder> Placeholder for a variable parameter.
|
Separates required parameters. You must use at least one of
(pipe symbol) these parameters in the syntax and you may use two or more of
them.
NOTE: To separate these parameters, put a space between
them.
[parameter] Optional parameter that you may include in the command line.

Syntax

Use the following syntax (separate parameters with a space):
Alm -f<filter name> [-ds<start date>] [-ts<start time>] [-de<end date>] [-te<end time>] [-all]
[-note] [-page]

You must check the Prompt for period box in the Defining Filters for Alarm List dialog when
you create a filter that you will access from the command line. If disabled, Alarm will use the default
period.

All Alarm command line parameters must be entered in lower case.
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Parameter

-f<filter name>

Description

Define the alarm list filter to use for the print.
If the name contains spaces, enclose the name in quotation marks
(""). You can also use the root filters: "Active Alarms" and "Alarm
Log".
Do not include a space between the parameter -f and the filter
name.

-af<filter name>

Change the filter used in the Active Alarm list. The Active Alarm
list will start with this filter selected.
This parameter will not send the alarm list to the printer.

-ds<start date>

Start date in the format yyyy/mm/dd or as an offset defined with
the $ parameter (offset in days).

-ts<start time>

Start time in the format hh:mm:ss or as an offset defined with the
$ parameter (offset in seconds).

-de<end date>

End date in the format yyyy/mm/dd or as an offset defined with
the $ parameter (offset in days).

-te<end time>

End time in the format hh:mm:ss or as an offset defined with the
$ parameter (offset in seconds).

-all

All columns are printed (otherwise the columns exceeding one
page are not printed)
This is equivalent to clearing the Cut to paper Width check box
in the Print form.

-note

Includes alarm notes on the printout.
This is equivalent to selecting the Include Notes check box in the
Print form.

-page

Inserts page breaks after alarm notes.
This is equivalent to selecting the New page after note check
box in the Print form.

-landscape

Landscape makes alarm print in landscape mode.

-item

Define the contents to include in the Alarm print:
l

0: Active Alarms

l

1: Alarm log

l

2: Active Events

l

3 Event log

-format<name>

Name of the format to be used. If no format is defined, then the
default format is used.

-csv

Output is to be exported as a comma-separated file (.CSV) and
not printed.
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Parameter

Description

The comma-separated file must either be saved at a location
using the -file<path> parameter and/or sent as an attachment to
an e-mail message using the -mail<address> parameter.

The -csv parameter must be specified
using lowercase letters only.
You can add a title to the e-mail message by using the -title parameter.
-file<path>

The full path to the destination file, including the name of the .csv
file.
The default filename is yyyy-mm-dd-hh-mm-ss.csv
The default file path is the GSS folder of the local IGSS installation.

-mail<address>

The output is to be sent as an attachment to the recipient's e-mail
address. If the output is to be sent to more than one e-mail recipient, separate any additional e-mail addresses with a semicolon.
You do not need to use the -file<path> to include the .csv in the email message, but if you do use the -file<path> parameter, then
the specified file will be included in the e-mail message.
If you do not use the -file<path> parameter, the default file name
will be used for the e-mail attachment.
Do not include a space between the parameter -mail and the email address.

-title

The subject line in the e-mail message.

-lfmt<format>

Name the alarm list format to be applied to the alarm report,
where the <format> is the format name to be applied.

-appenddate

Adds the current date and time to the filename.
If you have used the -ds (start date) and/or -ts (start time) parameters , the defined start date and start time will be used instead.

-ymdfolders

Creates year, month and day sub folders to store alarm list
reports when saving alarm list reports as a .CSV file to a specified
destination.
This parameter should be used with the -file<path> parameter.
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The parameter elements may not contain parameters of another alarm parameter. For example -affilter-all contains the filter name filter-all where -all at the same time is a valid alarm parameter

Job Scheduler example

This example prints the alarms matching the Analog Alarms filter. The start date is set to the previous
day ($date-1) and end date is set to today $(date). Start time (-ts) and end time (-te) are both set to 7:00
a.m. All columns are printed and alarm notes are included.

Program path:

"[IGSS InstallPath]\Gss\Alm.exe"
Parameters:

-f"Analog Alarms" -ds$(date-1) -ts07:00:00 -de$(date) -te07:00:00 -all
–note
Working folder:
Command prompt example

This command line prints all alarms matching the Purification filter from the previous day. The printout
shows all columns and includes alarm notes.

Alm -fPurification -ds$-1 -ts00:00:00 -de$ -te00:00:00 -all -note

Alarm Command Line Example

Alm -f"Priority5 and 6" -all -csv -maildk-igss-support@schneider-electric.com
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Chapter 5: Reference and Lookup
5.1 Conventions in this Manual
The following typographical conventions are used:

Convention

Description

Example

User interface element

When referring to labels and names
in the user interface.

User input

When the user has to type specific
data in IGSS

The Data Management tab.

Type the following description:

Incoming flow in Tank 2

Module
name

When referring to a module in IGSS

Note

A note emphasizes or supplements
important points of the main text. A
note provides information that may
apply only in special cases.

Tip

A tip suggests alternative methods
that may not be obvious in the user
interface. A tip also helps the user in
working more effectively with IGSS.
A tip is not essential to the basic
understanding of the text.

Alternative to this simple
find function, you can also filter on text in the messages
in Driver Log Filters dialog
box.

Warning

A warning is an important note that is
essential for the completion of a
task. In some cases, disregarding a
warning may result in undesirable
functionality or loss of data.

If you disregard the System
alarm, you may risk loss of
data in the LOG and BCL
files.

Open the Definition module.

By default, the timestamp is in universal
time format, UTC1. This can be changed in
the Driver Log Filters dialog box.

5.2 Getting Help in IGSS
IGSS comes with a comprehensive help system designed to help both system designers and operators to
get started with IGSS as quickly as possible.

Documentation overview
The IGSS documentation includes the following items:

1 Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating time in

most parts of the world. IGSS uses this time format internally in the database. You can switch between UTC
and local time by enabling or disabling the "UTC" field in various dialog boxes in the system.
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Documentation item

Description

Getting Started

An introduction to IGSS and its most fundamental terms and features.
Getting Started is intended to get you up and running as fast as possible. The manual provides a system and architecture overview followed by a number of real-life use cases you can go through before
building your first real IGSS project. The manual is available in Adobe
Acrobat format (.pdf).
For each module there is a help file with the same name as the module
itself, for example, Def.chm for the Definition module.

Module help

The help file is invoked by clicking the
in the upper right corner of
the module. The Table of Contents will then allow you to browse
through the topics.
For each Form or dialog there is a help topic with the following standard information:

Form and Dialog help̓

l

Overview

l

Preconditions

l

Where do I find it?

l

Field help

Form help is invoked by clicking the help button
in the upper right
hand corner of the dialog box or located in the Table of Contents of the
individual help file.
IGSS also provides thematic help. When there is a special theme that
requires special attention from the user, a dedicated help file is
provided. Examples include "Driver-Specific Help" and "Database
Administration Help".

Thematic help

Where are the help files located?
The IGSS help files are located in the appropriate language folder in the installation path of IGSS, by
default C:\Program Files\Schneider Electric\IGSS32\V13.0. The help files are available in English at
release time.
The paths to the help files are:

Language

Path

English

[IGSS InstallPath]\ENG

Danish

[IGSS InstallPath]\DAN

German

[IGSS InstallPath]\DEU

Translated help files
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Selected help files have been translated into Danish. If you require help files in your language, please contact Schneider Electric.

Help updates
The help files are continuously updated and improved. Check regularly with the IGSS Update in the IGSS
Master.

5.3 Version Information (IGSS Help System)
© Schneider Electric, IGSS Version 13.0
The IGSS help files are based on software build number 10305 (initial release)

English help files
To update the help files, click the Update IGSS Software button on the Information and Support tab
in the IGSS Master . There must be a connection from the PC to the Internet. Every time IGSS Update is
run, IGSS help files as well as IGSS system files will automatically be updated on the PC from the web
server at Schneider Electric.
You select the languages you want to update in the Tools menu of the IGSS Update form.
If you are not able to update the IGSS system directly via the Internet, the alternative is to download the
updates from the Schneider Electric website as zip files. These can then be transferred onto a CD or USB
memory stick, which is then the medium used to update on site.

After updating your IGSS installation , the build numbers in various IGSS modules may change to a
higher number. This signifies that the module in question has been updated with newer files. Build
numbers consist of four digits, where the first digit represents the year and the last three represent
the day number in the year in question. The build number can be seen in the About dialog box which
can be activated from the Help menu.
An example:

Build number = 10305
18 = the year 2018
305 = The 305th day of the year
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Chapter 6: Glossary
A
Application menu
The Application menu is the first ribbon in the IGSS Master module. Click the icon to drop down
the menu. The menu contains items that were typically found in the File menu in previous versions of IGSS. In most modules, an "Options" item allows the user to define global module settings. The Application menu was introduced in the Microsoft Office 2010 package. It replaces the
Application button (nicknamed Doughnut) which was introduced in IGSS V7 and V8.

D
descriptor
A descriptor is the graphical display of an object. IGSS includes many types of descriptors including: - Built-in standard symbols - Animated symbols (Symbol Factory library) - Graphics and
animation - Drawing symbols - Windows controls - ActiveX controls An IGSS object can be represented with different descriptors on different diagrams.

R
Ribbon
The Ribbon is a new term/element in the Microsoft universe. The Ribbon replaces the well-known
toolbars in applications. The Ribbon provides quick access to the most commonly used functions
in the application. The Ribbon is divided into logical groups (the tabs) and each tab is divided into
sections (the blocks in the tab). The Ribbon is context-sensitive which means that only relevant
functions are accessible dependent on the current user action.

S
SCADA
Supervisory Control & Data Acquisition

U
UTC
Universal Time Coordinated (formerly Greenwich Mean Time), used as the basis for calculating
time in most parts of the world. IGSS uses this time format internally in the database. You can
switch between UTC and local time by enabling or disabling the "UTC" field in various dialog boxes
in the system.
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